cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10

mj1856
Apprentice

I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.

 

I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:

 

Error1.png

 

 

 

I thought I would try to reinstall the MF Toolbox utility, but there are two problems.

 

1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.

 

2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:

 

Error2.png

 

I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.

 

I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.

 

Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.

 

(I can use the printer functionality just fine.)

1 ACCEPTED SOLUTION

Thanks.  My model's links are different, but the new software appears to work.

 

https://www.usa.canon.com/cusa/support/consumer/printers_multifunction/imageclass_series/imageclass_...

 

Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

434 REPLIES 434

Dear Darius,

 

thansk for the response! Although interesting to know, the question if I should load firmware from the US was only a very unimportant side question. The main question I have, as stated here is why the scanner is not working anymore and how to fix it. Would be great if you could help out!

 

@al1 Thanks for the suggestion, but advising people not to update their computer is generally a bad idea. I rather have printer issues than a ransomeware whiping out all my data. And I know people can be nostalgic for the good old days, but running XP is not sensible anymore if one is planning to connect to the internet.

https://www.cvedetails.com/vulnerability-list/vendor_id-26/product_id-739/Microsoft-Windows-Xp.html

 


@Haeri wrote:

 

@al1 Thanks for the suggestion, but advising people not to update their computer is generally a bad idea.

 


@haeri  I specifically said: " I don't automatically update Windows 10 anymore. "   

I did not advise people  to not update their computer software.  I pause these updates for Windows 10 and check out what people are saying about them before I press the Update button. I hope that provides you with more clarity. 

Hi Haeri.

 

If the MF Toolbox's buttons aren't responding (per your gif), even without an error message, then something on the computer is stopping the program from responding.  You can check for any conflicting software, and if you're on WIndows, you can check the TWAIN_32 folder (close all imaging/scanning programs, move everything from the folder except WIATWAIN.ds, then try the MF Toolbox again).  If the TWAIN_32 check works, then the problem is that another scanning, imaging, or video recording program is conflicting (I've also seen interactive whiteboard software cause this).

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Hi Darius

 

I have only two items in my twain_32 folder: "wiatwain.ds" and a folder called "MF4100". But if I remove the "MF4100" folder, the MF Toolbox states that there is no compatible scanner installed on the system.

 

I have also checked that I have no other programs running. I have also no whiteboard or similar program installed. Do you have any other suggestions?

Hi Haeri.

 

If moving that folder didn't correct the problem, then something else is affecting the computer's ability to communicate with the scanner, and to operate that software.  You'll need to contact your computer's manufacturer for further troubleshooting.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Darius,

What about my problem?  And the original post's problem (which should be the same)??

 

Toolbox worked when I installed windows 10 (new drive).  Then, and month later, it doesn't work.  There were a bunch of MS Office, Visual Studio's, TI's Code Composer Studio, even notepad++ installed.   Removing them one by one to see when your tool box starts working isn't an option.

 

Maybe, if you shared some information like what what the connection is SUPPOSED to be, I could try troublehooting it myself.  Sicne the support from Canon is non-existant.

 

Because YOUR software with YOUR product (imageClass MF 4890dw) telling me this,  is of no value. (which has the updated firmware, as I indicated a few posts ago...)

 

 

toolboxFail.jpg

Haeri
Contributor

Just a quick Update:

I never managed to get the MF Toolbox to work again, but I found out that there is a free official Microsoft Scanner tool which actually works really good! 

 

Here the link to the Microsoft Store page:

https://www.microsoft.com/en-us/p/windows-scanner/9wzdncrfj3pv?rtc=1&activetab=pivot:overviewtab

 

Hope this helps.

I just had this happen in the last few days.

I messed with it for over a day, uninstalling, re-installing. Then I found there was a firmware update, and then trying again over and over. It was getting worse; for a while even the printer wouldn't work.

 

I found the microsoft scanner ap, free in the store, and it worked, but only single page scans.

 

Whenever I tried to run MF toolbox 4.9 , it always said no scanner installed, even when it was online and ok in the windows printers and devices.  Finally I tried "run as administrator" for MF toolbox, and it works ! Finally, just set it up permanently in the executable file's properties and no more troubles. 

 

Your welcome.

I would say thank you...  But setting to run as Admin didin't work.

 

I suppose Canon is ACTIVELY trying to drive customers away with their non-support.

Yvan67
Apprentice
Oh well. Perhaps try deleting everything again, I had to delete from windows printers and devices , because there was some internal error, re-installing everything , and then going from there.
Avatar
click here to view the press release
Announcements