Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

433 REPLIES 433

When I get "A supported scanner is not installed. Please install a supported scanner, and then restart Toolbox." message, then I open Toolbox with administrator privileges (even without patch - I'm not sure if it works, because it never helped me 🙂 and scanning is OK (but only from Toolbox, it won't work directly from device).


When you uninstall drivers:

- I would recommend uninstalling them in normal mode and if needed, manually delete devices from list in Windows Device Manager if they still appear there (doing it in safe mode caused some problems for me, because it didn't delete drivers and devices entirely)

- uninstalling anti-virus software in safe mode might me a good idea - once it solved my scanning problems

- try not to install patch for scanning after reinstalling drivers and Toolbox and just run Toolbox with administrator privileges.


Within few hours I'll try to reinstall my drivers and I'll see how should devices appear in device manager.

I tried every solition that worked in last few months, but I can only scan using Windows Scan app or Toolbox running with administrator privileges. Scanning directly from device (which is very handy for me) is not possible. My workaround for that is using Remote Desktop on my tablet to control Toolbox when I stand next to the printer.

Exactly the same problem is preventing me from working!

Scanning directly from device is impossible with the current Canon MF Toolbox !

What is the problem, I am not sure. But it DID work with previous win 10 updates, and after it updated last month it stopped!

This is the error every time I choose my PC from the MF 6140dn!

canon error.png

I can manually start up the stupid toolbox and it would scan from the software, but it won't when I send scans from my device!

inb4 "Hurr durr, try the common fixes"
I've already tried the following:
Uninstall with wipe of LEFTOVERS: drivers 
Uninstall with wipe of LEFTOVERS: MF toolbox
Install them again with restarts, different versions, different order.
The "Fix" patch for the network and usb scanner didn't work. (NetworkUSBScanPatchEN.exe)

Firewall has exceptions for:

%ProgramFiles% (x86)\Canon\MF Toolbox Ver4.9\MFTBOX.exe

%ProgramFiles% (x86)\Canon\MF Toolbox Ver4.9\TBOXCFG.EXE

%ProgramFiles%\Canon\Canon MF Network Scan Utility\CNMFSUT6.EXE

Firewall was turned off. Didn't help me.

Wiped clean Windows/Twain_32 directory, didn't work.

Tried installing on another 64bit win 10 machine. Didn't work 😞



You may want to try uninstalling your antivirus software. It helped me few months ago (I had Kaspersky Total Security).

Two times reinstalling last Windows update brought Toolbox back to work. (but it didn't helped me during lat few updates)

What's interesting is that when Toolbox stopped working, Windows Update was the thing that brought it to life (2 updates from june to july). August update killed it again...


I recommend to install Remote Desktop on your phone or tablet, and use it to scan when you're next to your printer - it always work and you won't loose your time for Toolbox anymore...

I am sorry, but I can't uninstall the antivirus of a Domain computer.
The company uses Trend Office Scan Antivir, there are no exceptions either, because it's configured on a server. 

Being in a company domain, I can't remote connect it either because of the security restrictions.

After the last Windows 10 Update (at the beginning of this month - it was KB4346783) scanning from device and using MF Toolbox without administrator priviliges is possible with no problems. I didn't take any other actions to restore those functionalities...


Maybe it will also "repair" the issue in your case...

Thanks for the news / hope. I'll try later this week. So far nothing in this thread has worked for me.

Thanks, GregoryNazar! It appears MF Toolbox is working for me again after a long time.


For others' benefit, I don't have KB4346783 listed in my Win10 Update History, so it seems likely it was one of the following:


- 2018-09 Update for Windows 10 Version 1803 for x64-based Systems (KB4100347)

- 2018-09 Cumulative Update for Windows 10 Version 1803 for x64-based Systems (KB4464218)

- 2018-09 Update for Windows 10 Version 1803 for x64-based Systems (KB4456655)

I'm happy it worked.

Just be advised: next update may crush it 🙂 Few months ago Windows Update also helped me, but update that came about two months later seized scanning functionality. If that happens, you should try opening Toolbox with administrator priviliges and for remote scanning (from your Canon device) try Remote Desktop.

I just had to rebuild the operating system on one of the computers on my 4 computer network 2 days ago and wasn't even able to get the Canon Toolbox to Operate - The same thing everyone else is talking about.  "A Supported Scanner is not installed etc....".  With that I did a complete removal and reinstall of the drivers along with the patch that on the Canon website.  <The mark of insanity is when you continue doing the sam thing expecting to get different results.>  I reinstalled it twice and now not even the Canon Toolbox Icon shows in the Apps on my desktop.


There is a "Canon Office Printer Utility"icon that shows up in my apps (I believe that it was something that Canon's Web Site told me to download.  When I go to that app it responds but nothing happens.


So now yesterday morning I scanned several items from my other compluter and then in the afternoon it started giving me the same message.  It was then, after reading all of this business that I put it together that Yes-I like any good microsoft owner had performed an update midday yesterday.  So now I understand why Microsoft is in such low regard by so many people.


At this point at  I have a worthless Icon on the one computer and none on the other so I guess I won't be doing any scanning until someone develops a fix for this!  I'm not dumb, but I'm not extremely fluent the in's and out of all this IT jargen and need these Guru software people to give me a fix that can be easoly explained in a few steps!


Pleeeeeeeeeease Canon and Microsoft gets your ducts together and stop wasting our time and Money!!!!!!!!!!

Canon takes a netoriously long time to resolve these kinds of issues. It took a long time for the last scanner patch. The Windows Fax and Scan app seems to work in the mean time. 

01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.