cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10

mj1856
Apprentice

I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.

 

I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:

 

Error1.png

 

 

 

I thought I would try to reinstall the MF Toolbox utility, but there are two problems.

 

1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.

 

2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:

 

Error2.png

 

I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.

 

I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.

 

Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.

 

(I can use the printer functionality just fine.)

1 ACCEPTED SOLUTION

Thanks.  My model's links are different, but the new software appears to work.

 

https://www.usa.canon.com/cusa/support/consumer/printers_multifunction/imageclass_series/imageclass_...

 

Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

433 REPLIES 433

THANK YOU!

Thank you so much for your solution. It works immediately! To think I almost uninstalled / re-installed, bought new software etc.

You saved me a lot of needless aggravation.

Thanks, worked for me on Image Class MF4350d even after reboot. Only issue is Windows Fax Scan doesn't work, but I'll use MF Toolbox instead.

had this issue.  windows 10 started getting worse... store apps no longer opened, etc.  i did a re-install of windows 10 from microsoft (not laptop manufacturer).  all was working for weeks until windows update (as this issue occurred before)... microsoft visual c++ 2010 x86 redistributable 10.0.40219 kb2565063.  

 

this time, i just uninstalled and re-installed in this order with reboots in between each and scan is working.  thought i tried this before and it didn't work but might not have done reboots in between (too long ago to remember!).  

 

reboot

uninstall mf###-###

reboot

uninstall canon mf toolbox ####.mf##

reboot

install mf####-###

reboot

install canon mf toolbox ####.mf##

reboot

 

if it stops working again, before uninstalling / re-installing, also try:

powering off your pc and printer

unplug the usb from your printer to your pc

powering on your pc and waiting until it's been up a minute or 2 (for services to finish starting)

powering on your printer and waiting until it's been up ~ 10 seconds

plug the usb from your printer into your pc

open the canon mf toolbox #.# manually

switch the printer to usb scan (if desired)

press the start button on the printer

 

 

Does Canon not realize how many customers they are losing and the extent of negative word of mouth publicity it is getting? How long can Canon make its customers jump through loops before coming up with a fix to this problem?

Make sure that the LCD display shows "USB SCANNING."    Press the "SCAN" button above the display to select.  

On i-sensys MF8350Cdn (German device name) I had the same problem with not functioning scanner after upgrading to Win 10. Using the guidance of Piers_A  from 08-19-2015 the scanner is working properly. Many thanks for the perfect solution!

Outstanding thanks kjv for refering us to Piers_A on 8-19-2015.  I too was having this problem and this fixed it.  Kudos to you and Piers_A.  This needs to be broadcasted to everyone that has responded with this problem.

This is absolutely the right fix for the problem......was driving me crazy since the print function was fine.....Canon community is a big time help.

This solution works on my MF4270.   Called Canon tech support twice, and all they do is uninstall/re-install drivers (which only fixes the problem until you reboot your computer and the fix is lost again).  Canon tech support should really have pointed this fix out in the first place. 

Announcements
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version 1.0.5.1 is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
12/07/2022: New firmware version 1.7.0 is available for EOS R6
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.