Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

434 REPLIES 434

I said that I tried that... "I setup WMI as suggested (log on, recovery, etc.)".

Windows 10 x64

You are right. Does not work. Thanks.

I solved the problem.  I went to Office Depot yesterday and bought a Brother DCPL25, for $129.99.  Canon will never fix this problem because it is not in their financial interest to do so.  It worked well with all systems before windows 10 and still does.  They have moved on, just like I have moved on from Canon forever.


Trying to fix this is like beating a dead Mule.  He ain't going to ever work again. And your Canon printer and MF toolbox ain't ever going to work again, like it should.  Give it up.  Take your life back.  Don't fret and worry and waste your valuable time  trying to fix and patch something that can't be fixed and patched, for long.  Move on.  Get on the train or get left at the station.  Chalk it up to experience.



I beat you to it Chupacabra, by quite a long way and a Brother  MFC-8520DN. The Canon went into a skip. It was such a joy.

Now I can print and scan locally and remotely from Win10 and Linux.

i hear ya.  i'd probably pay $100+ to have back the ~ 10 hours of trying to figure this out.  but i have a workaround that usually works.  but now that i've done the below, i'm thinking this won't reoccur.  


i got it working using system restore last night.  this morning, it stopped working again.  i restored again.  this time it didn't work.  i restored again.  still didn't work.  last, did a recovery (enter 'windows update' in search, select 'check for update', in the new window select 'recovery', etc.).  btw, i recommend doing a system image backup 1st, just in case you lose something.  i didn't lose anything but you never know.  it did a 'cumulative windows update' in the background.  i went to services.msc, stopped and disabled 'windows update' service.  restarted.  the scan is now working.  i'm hoping that it will continue working since i believe the cause is a windows update.  even if you have the 'windows update' service stopped, i believe it will start if you select 'check for updates' within the 'windows update' window... so don't!  

in particular, i believe the issue is being caused from upgrading microsoft visual c++ 2005 redistributable 8.0.59193 to 8.0.61001... but i haven't been able to confirm.

bobdan, congrats!  You know, sooner or later everyone will see the lightbulb in their brain click on, and they too, will abandon Canon and take the plunge.  I got the DCPL25 because it was all I need.  I don't scan that much, but when I do, I want something that will work.  There is no sense to go down with a sinking ship. 

its works with my MF6140dn and Win10pro x64



 In start menu, search for Services. Find "RPC (locater)" file. Make sure it is running--not on manual. "Start" it.

Then restart PC. Next, make sure all apps are off and that your Canon MF toolbox is closed. Open task manager (contrl/alt/del). Expand to "see less" so you are seeing everything. Go to "Windows Processes" section. Find "Service Host: Windows Image Acquisition." Don't hit the left arrow to expand it. Just click to highlight it. Then "End task.

" Check "abandon data." "Shut down." Exit task manager.

NOW--set your MF4150 to scan. Put your doc in. Open your MF4150 toolbox on PC. IT WORKS!


RPC service is already set to automatic and running.  i don't want to have to kill a process and abandon data each time i want to use the scanner but it's not a bad alternative.  could easily create a script for it too.  


what i'm doing isn't ideal either (system restore or recovery then stop and disable the windows update service) but i no longer have to do anything, it will continue to work until i update windows, and a fix will be provided eventually.  



i like this laser printer / scanner / fax and while it took a while to figure out what caused this, IMO the minor inconvenience of not doing windows updates (or killing the WMI process) is worth ~ $150 and not going thru the hassle of purchasing a new printer / scanner / fax, etc.     

I dont kill (WIA) process, only did full reistall drivers and set RPC service automatic startup.
Its works for me, scanner is working well now.

Thank you Iggytwo.  Your first post of 1/25/2016 worked like a charm for me and my MF4150.  I had tried the other recommended fix which did not allow me to scan but your directions worked perfectly.  My scanner is now operating just as it was a few months ago.


03/30/2023: New firmware updates are available.

EOS R3 - Version 1.4.0

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

03/28/2023: New firmware version is available for EOS-R5 C
03/14/2023: New firmware version 1.8.1 is available for EOS R6
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.