Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

435 REPLIES 435

Yup this works.   Windows 10 auto-detected my Canon D420 and installed a Windows driver, but Windows Scan could not detect the scanner.   Be sure to remove your printer/scanner in Devices and Printers, disconnect the printer/scanner cable and then go to Canon's site to get their driver.   Install the driver and when prompted connect the device to the computer.   Your device will be installed automatically.   Now run Windows Scan and bingo.

yes, it will scan using windows fax and scan, but it will not install the toolbox, therefore not allowing you to scan to a PDF file. I also have the D420, and the tool box will not install, period.


The Windows app "Scan" has a pull down to select the file type. Seven to choose from and for me PDF is one of them.


Is it possible for there to be so much difference between my MF4770N and other models?


I also use the toolbox with my windows 10 installation- I only know about the "Scan" app because I found it along the route to getting the toolbox to work. But the Toolbox works for me.


As far as Canon issuing a fix...I think they think they already have, and I think they don't read these forum posts. 


Best of luck.



I have the D420, and there is a pull down.  Except that there are only 4 types of files to choose from;  BMP, JPG, PNG, AND TIF.


There are a multitude of differences between scanners.  Canon can fix the install of the toolbox on some models of scanners, but  on others, it says the problem belongs to Microsoft, and the computer manufacturer, which is in my case, HP.  So Canon has done all it will for people with the D420, as of right now.  But, Canon is still selling the D420, and it  has the same issures. I can get my scans to a PDF file, but not through my Canon Scanner.  People that buy a new D420 will not get a toolbox, therefore, they will not miss it.  (Canons' theory and business model, in my opinion)


Finally resolved!

1. Uninstall the drivers and MF Toolbox

2. Download and install drivers and Toolbox from here:



Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

@mj1856 - The page that you linked to, and really the updated Toolbox, i.e., [Windows 32bit & 64bit] Tool Box Ver. doesn't mention a word about uninstalling anything in Safe Mode or otherwise under its related How to section:

Canon MF Toolbotch.PNG


Like so many others posting here in this thread and many more I'm sure suffering the same inconvenience, I have been stumped as to how to get the scanner utility to work post Windows 10 upgrade.


For the record, my system's particulars:

Windows 7 Pro (64-bit) to Windows 10 Pro 64-bit)

Color imageCLASS MF8580Cdw


In my impotent efforts last week, I downloaded and installed:

Canon MF Toolbotch2.PNG



However, the problem remains, the scanner doesn't work. Furthermore, the toolbox looks the same upon launching as before the update:

Canon MF Toolbotch3.PNG



At the top of this thread, somebody has decided that the issue has been Solved!. It seems that at least two people believe this to be true, but I don't. If something needs to be unistalled in Safe Mode (or any mode), Canon needs to clearly spell that out as well as any other pre-installation procedures.





Forums as a support tool require patience and persistance as few actual employees of the company particiapte in them, and most all the posters are really trying to be helpful. Mine works so I have a EUREKA! moment and in my happiness I announce a cure only to find out is is "not-so-much" for everyone. OOPS!


This is, believe it or not, what I have seen with scanners of all brands with every OS version upgrade from Win 3.1 to Win95 to Win 98 to Win XP to Win 7 (I skipped Vista) and now to Win 10. Not the half hearted attempts sometimes, as Vivitar simply said "No Driver" for one of them. HP did that for my $1000 Color Laser All In One 2840 when 7 was released (ouch!). Same status - print but no scan - but With Win 7 I could use XP Mode to run the XP scan software (which would not run in Win 7).


Of all the folks I have discussed the move from Win 7/8/8.1  to Win 10, scanners is the problem I hear most that is not likely a user issue.


Because of all the differences between components in the open PC model, it is possible that your particular system has a device with a driver that won't work with Canons'. Maybe something that seems totally unrelated like, for example, a video driver. I had a case where an upgrade to an Intel video driver caused a payroll application to print everything is a wrong location on the check. When the (Timberline) Sage Support Tech told me to roll back the driver I thought he would then tell me to take a burlap bag and go collect snipe or something, but it solved the problem.


Keep at it or figure out how to contact Canon (I mean really contact them as they may not monitor the forums regualrly if at all). 


And if you get it to work, post your solution that might help someone else even if it's not everyone else.


Good luck!



There is an app that will work.  It is free for 30 days and then costs about 40 bucks.  Uses the Canon drivers.  If someone else can make a utility that will scan to PDF, it would seem like Canon could, or would too.


The name of it is Vuescan.  I'm using it and so far it works perfectly, with more options that the toolbox.  And no, I am not hawking it.  I am just tired of not being able to scan to PDF.


Charles (the chupacabra)



The toolbox icons for .pdf and ocr do not look the same. Clicking on any buttons would not bring up the dialog box.

click here to view the gallery