Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

434 REPLIES 434

Is it free at the Windows Store?

@gnocchi wrote:
Is it free at the Windows Store?

Yes, it was free. This is the one I used:

Windows Scan


After messing around with this myself I got this to work but doing the following:


1. turn off printer, if you don't when windows 10 boots it may auto detect it and install (which I found screws this all up)

2. uninstall the MF Toolbox and driver if installed then reboot windows 10

3. After reboot and login turn printer back on and make sure it's connected to network (test ping and config page)

4. Install driver, it should detect printer but if not try entering the IP, and make sure MF Scan  appears in notification area.

5. Install MF Toolbox for windows 8.1 (v4.9)

6. add inbound and outbound firewall rules for:


%ProgramFiles% (x86)\Canon\MF Toolbox Ver4.9\MFTBOX.exe

%ProgramFiles% (x86)\Canon\MF Toolbox Ver4.9\TBOXCFG.EXE

%ProgramFiles%\Canon\Canon MF Network Scan Utility\CNMFSUT6.EXE


7. modify the MF Toolbox configuration (just go in and then press OK)

8. On printer test scan and it should show your computer

I followed your instructions and it works! However, after not using my printer / scanner for a couple of days, I need to uninstall, reboot windows 10 and install MF Toolbox again. Do you have any advice?

Did use an uninstaller like Revouninstaller first?

No, I didn't

This actualy worked.

Thank you!

TheTasmar's procedure, posted on 8-5-2015, uninstalling then reinstalling the driver and MFTBox.exe, worked for me, without setting any firewall rules for any executables. The printer is connected via USB, I have Norton 360 installed.

Does not work for me. Ethernet cable connected to router.

After upgrading to windows10 my MF toolbox doesn't work anymore. I tried to uninstall the toolbox to install the new and it will not uninstall. Anyone have a solution to this issue?


thank you,