Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

434 REPLIES 434

I guess the best solution is to diversify across brands and models within each brand.


I got hit because our office had mostly the exact same model of Canon MFP (MF4690). But, we have other brands: one Xerox (drivers no longer updated but hardware is awesome), several Panasonics (on the biggest one, the rollers keep generating false "needs replacement" errors, but the others are solid), one OkiData (worst MFP I've ever seen--no one will use it), several HP (drivers absolutely refuse to install on Win10 for a handful of them, and these are BRAND NEW HP MFPs, bought after Win10 came out!!). Our office was able to get by with the Canon users asking the other users for help. We simply returned the brand new HP MFPs that wouldn't install.


Strangely, the Canon DR-C125 and DR-C225Ws we have work fine and had no trouble with the Win10 upgrade. So it's a total crapshoot. There is no way of knowing which specific model from which brand will be solid and fully-supported. The Canon MF4690s were awesome through WinXP/Win7, so we bought tons of them, but they all died as soon as Win10 hit. We were fooled by their reliability into buying a big batch. We won't be doing that again--we'll diversify on purpose.


For the software, I blame the hackers who have caused Microsoft to secure all the underlying drivers which left the hardware makers scrambling to hire driver developers. Bad hardware = no excuse.

i was wondering what the reason was for recently receiving multiple notifications about this 'old' issue...


scanner was working until latest windows 10 update 28084 on 9/27/2016, which i read others have been receiving for previous month.


i checked canon site for printer / scanner model (for me mf4370dn) and there is a new update available as of 9/23/2016 (previous update was 7/7/2016) for the Toolbox (Ver. and patch for USB scanner. note: the drivers have not been updated (latest update available is 7/7/2016).


i followed steps pasted below and USB scanner works again.
also, i pasted a link below to full steps that i've performed in the past as well.


personally recommended steps to update canon SW:

  1. disconnect canon USB from PC
  2. reboot
  3. uninstall canon mf toolbox
  4. reboot
  5. install canon mf toolbox (double-click to extract files to Toolbox folder, double-click Toolbox\Setup.exe)
  6. reboot
  7. install patch for USB scanner (double-click to extract files to NetworkUSBScanPatch folder, double-click NetworkUSBScanPatch\UpdateProgram\UpdateProgram.exe)
  8. reboot
  9. connect canon USB to PC
  10. scan (note: you'll have to update your preferences e.g. PDF vs. JPEG)

link to full steps that i've performed in the past (in case you still have problems):

Thank you for posting your solution to your problem.


However, the reason for additional entries on this "solved" issue is that for many of us it is not solved and nowhere close to being solved.  The reason it is marked 'solved' is that one person managed, on their own, to get the problem fixed FOR THEM.  For the rest of us we have have issues that encompass many different issues all revolving around scanning and MFToolbox.  For isstance, it took me over four months to uninstall and reinstall Toolbox and that only got me back to my original problem of Toolbox not recognzing my scanner (not on a network).  It has been three or more months now since then and no new communications from Canon.  Others have similar issues revolving around scanning, scanner recognition, networking, etc. 


Clearly Canon has not allocated any resources, to my knowldege, to fix this vexing interaction with Windows 10, and like most tech companies they refuse to communicate with their customers about progress, if any, on issues important to the customer.  The clear lesson is that once you buy a Canon product you are on your own.  Period.


Call me delusional but I still fantasize that somehow, some day, Canon will have the blinding epiphany that if they want to have return customers they might, actually, just a little, pay some attention to their current one.  But, as I said, I'm delusional.

hi reba
i was referring to 'old' problem because it was working until the latest windows update. i understand that some people might be in different situations. as far as i'm aware, all of the steps that are needed to fix this issue are included in my previous post. i wish you luck.

You need to call Canon's support phone number. They will walk you through the process. I have 2 Canon printers that had this issue, but no more since they helped my over the phone.

The last time I called Canon phone support they swore up and down that my problem was that I was using a 6 foot USB cord and not a 3 foot USB cord.  I challenged that thinking but the guy doubled down saying that it was ll over their database that this was the problem with Windows 10.  Much against my better judgement, but willing to try anything, I tried that.  Of course it didn't work.  I have no faith in Canon.

Problem is not with cannon will has provided a win10 driver and toolbox app. It is with other third party drivers. That's at least what my understanding is ...


Found solution for my case.

1. Uninstall previous drivers

2. Uninstall Toolbox in safe mode

3. Install new drivers downloaded from Canon (updated for Win10)

4. Install Toolbox in safe mode (also downloaded from Canon, version ToolBox_4911mf17_Win_EN)

Now working fine.

Didn't delete any driver from Windows/Twain_32 directory. 

@obsobs wrote:

Found solution for my case.

1. Uninstall previous drivers

2. Uninstall Toolbox in safe mode

3. Install new drivers downloaded from Canon (updated for Win10)

4. Install Toolbox in safe mode (also downloaded from Canon, version ToolBox_4911mf17_Win_EN)

Now working fine.

Didn't delete any driver from Windows/Twain_32 directory. 


I see why you had to go SAFE MODE to uninstall the Toolbox - I was unable to uninstall it in normal mode. So I didn't uninstall it.....

Hopefully this solution will work for all Toolbox users!

The downside is the Windows Scan App now has issues, but I am not too worried about that one!

Thanks for your post!

I too am having the same problem after having upgraded to windows 10.  I am not exactly sure how to uninstall the drivers as you and others have suggested.  Could you possibly give a few more details?


thank you