Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

434 REPLIES 434

The Tasar's solution worked for me on a brand new Windows 10 machine. I installed it once... didn't work. repeated these instructions... now it's working.. no idea why, this worked also on my previous computer. I can't explain it, other than I'm very glad these instructions were posted. Try them before you dismiss them.


I have been having similar problems. Uninstalling and reinstalling MF toolbox didn't work. 


Canon, please update the driver.

I found the solution to this problem. You want to remove other driver folders in Windows/Twain_32 directory. I manaully removed Creative folder and it worked. I guess my creative cam doesn't work anymore, but that was coming for a long time. 

I also Same Problem in my Offic Printer. So please give me suggestions.

Geek Assured Tech Support in USA

As I said before, if MF Toolbox does not work after Windows 10 1511 update, that's how i solved the problem after few hours of frustration.

Thanks a bunch - this worked for me! When I went to try to scan, MF Toolbox would freeze up and not do anything.  I tried uninstalling and reinstalling to no avail.


I went in and deleted the entire driver folder under the Windows / Twain_32 folder.  It's not easy to find the folder so I searched for Twain_32 and it came up.

Yikes, huge update !!! Thats usu when things go wrong!!! I like to wait a few days at least after a major update before I do it myself in case it causes probs and then it gives Microsoft a chance to work the bugs out of their updates.

Is there a place where you can report issues to microsoft regarding win 10 probs/conflicts(like this printer issue)? and if so, do they listen?

 it wont let me delelte i even tried renaming it then deleting it...wont let me delete that file 

Please click the link 


4 Ways To Boot Into Safe Mode In Windows 10 (



You can then log in in Safe mode


Go to Control Panel / Program and Features


You can then delete Canon Tool box



(Note: I don't know why but obviously Canon Toolbox can only be deleted in Safe mode in Window 10)





Hi! Have same problem.

But even can't reinstall MF Toolbox. Installer after asking some qustions just stop responding. Uninstaller does the same.