cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Insufficient privileges to install Canon MF414DW

keebcanon
Apprentice

Hello!

 

We have 5 new computers for which I'm trying to install the drivers for the scanning capability, but it won't install.

I keep getting the following error:

 

"you do not have sufficient privileges to install the program. Log on again with administrator privileges"

 

All 5 users are administrators.

I've right clicked on the install folder and chose 'run as admin'.

I've done the same to the actual driver install file.

 

I've checked security measures and nothing is blocked.

I can print to that printer.

 

The function we need is to scan from the machine to a specific folder.

It's currently set up from the 'old' computers to do that.

 

These are new HP laptops with Win 10 business version 1909 build 18363.836

 

The printer is the MF 414DW.

 

Cheers,

Brian

 

15 REPLIES 15

Darius
Whiz

Hi keebcanon.

 

The first account on a Windows computer is typically limited in power, even though it will commonly be listed as "Administrator."  Additionally, as work computers, they may be pre-setup to give authority to a networked IT or Admin account in the workgroup.  There is nothing Canon-side that can preempt administrative privileges or lack thereof.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thanks Darius. I appreciate you taking the time to answer.

I'll follow up with our IT person. I'm under the impression that this admin account is the full deal, but I could be wrong.

 

I'll post back with any results we may have for anyone else possibly encountering this issue in the future.

 

Cheers,
Brian

"Nothing Canon can do" response is wholly inadequate and unacceptable.  I bought a Cano imageCLASS MF445DW and cannot install the MF Drivers though I am the Administrator, the 1st account on this W 10 Pro 64-bit Dell Laptop.  There is no workgroup, no IT support - it's my personal and work laptop.  Tomorrow (Mon. Feb. 1) if Canon Tech Support doesn't fix ir pronto, I'll send it back for a full refund.  Period.

"There is nothing Canon-side that can preempt administrative privileges or lack thereof."

 

I think the problem has been misidentified and thus, incorrect courses of action are suggested. It isn't a lack of administrative privileges as most people I see looking for help are indeed administrators. I'm a domain admin and I can't do it.

 

Canon has made a poor installer with obscure requirements that no other manufacturer has.

dcfitz
Apprentice

I had the exact same problem and found only one way to fix it.  It just takes a few minutes.

 

-Go to Manage Your Account>Other Users

-On the right, click on Add someone else to this PC

-Select a new log on and then make sure you grant it Administrator Privileges (You may have to create it and then go to Modify and grant the Admin).

-Restart you computer and log on with that ID.

-Run the Software and select "Shared Printer".

 

Restart with you original log-on and you should be able to scan to it.

 

You can then go in and delete the new Log-on you created and the printer will still scan.

 

The above looks harder than it is...it is really quite easy.

 

On what device?

dcfitz
Apprentice
Follow the above instructions and it works well. I know it is frustrating but it worked for me and I love the printer now.

pgreen
Apprentice
My solution was simpler. Since I already had administrative privileges, I guessed the problem was that the "setup" program mostly runs several subsidiary programs, and just because you run setup as an administrator doesn't mean that the subsidiary programs run that way too. Instead, I opened a command prompt as administrator, navigated to the folder where setup was located, ran it from there, and it worked. Presumably, that meant that everything that ran in that command box, including the subsidiary programs, was running with administrative privileges. In the interest of full disclosure, I actually was installing the drivers for an MF8580Cdw, but I have had this problem with multiple Canon printers.

mparker
Apprentice

Azure AD joined machine, user accounts on the machine are Administrator and Global Administrator and none of these accounts can install the MF642cdw, MF743cdw driver packages.
This is unacceptable! Canon blames Microsoft Permissions and over at Microsoft they blame Canon installers!
I personally believe this to be a CANON issue as the administrative permissions are properly set on over 200 machines in the organization! 

You cannot expect an IT Admin to manually create local accounts for 200 users just to install a printer driver! That is unacceptable Canon!
Every driver from every other manufacturer works with Azure AD joined machines. Yet Canon wants to blame the permissions?

 

If you choose the USB option it has no problem installing the driver. Yet it obviously stops when it cannot locate a USB-connected device.

When you choose the Network option it is supposed to open up holes in the firewall to allow the driver to communicate with the printer yet stops you at the error message "Insufficient privileges to install Canon MFxxxCdw driver.

Please get this fixed as it is truly a problematic issue! It is obvious there are many people trying to get this to work and "RUN AS ADMINISTRATOR" should work yet doesn't. Run as an alternate user should work yet it doesn't!
We are not dealing with local accounts we are dealing with Corporate machines joined to AZURE AD

 

Announcements
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
10/14/2022: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
09/19/2022: New firmware version 1.0.4.1 is available for EOS C70
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!