Showing results for 
Show  only  | Search instead for 
Did you mean: 

Error message on my MX700 Printer: U052 This type of print head is incorrect.


I got this after installing new ink - it worked just a bit and then when I turned printer off and on, got this msg.  I took out cartridges and head, put them back in, and no change.


Didn't work for me. I don't understand why would printed out one page just fine and then malfunction this way.

That makes another

but the procedure worked

I have tried it four times since I got the error.  No luck.  I hope this happen doesn't befall my MX860 as well.  I noticed that this seems to happen with a few models(based on other posts that I have read.)


Having the same problem what a pain as need to print some papers off ! watch this space printer is off !!Smiley Sad

Help have done everything it says & still not working ?

Hi choc1970!

Welcome to The Canon Forums, and thank you for your inquiry!

We appreciate your participation, however we need to let you know that the Canon Forum is hosted and moderated within the United States by Canon USA. We are only able to provide support for Canon products manufactured for and used within the US market.

If you live outside the United States, please click here and select your country or region for your support needs.

Feel free to discuss Canon products sold outside of the United States, but please be aware that you will not receive support directly from Canon USA.

Still didnt fix the problem though did it :smileysad Smiley Sad Smiley Sad whether it be the UK or wherever the item has broken & I have to get a new one definately not a Canon


Got this message last week on my trusty PIXMA MP960. Tried all of the procedures mentioned above at least a dozen times with no luck. Then I unplugged and let it sit overnight, In the meantime I removed all of the ink and the print head and cleaned the excess ink off the printhead ink jets. Next morning I plugged it, reinstalled the printhead, installed the ink, turned it on and viola! it worked.  Then I decided to test it by printing a test page.  Everything looked good except for the top black ink pattern for the PGBK ink cartridge, the print was so faint and blank as to be almost non existent. I did several head cleanings with no luck, then did deep cleaning with little success.  I created a test page that had a full page of letters and printed it 3 dozen times and started to get better results but still had areas that did not print well.  Decided to buy print head solution to cleana and "unclog" the jets thinking they may have dried out when the printhead sat overnight with no ink in it. Did a thorough cleaning and reinstalled everything. Turned on the printer and got the dreaded U052 message!  I've tried to repeat what I had done previously but no luck. Even bought another print head off of eBay but I get the same error msg so I don't think it is a printhead issue. Love the printer, scanner specs are better than any other current models regardless of brand and prints pro photo quality prints. Want to save it, so I'm bundling it up and taking it to a local Canon authorized service center even thought it is out of warranty.  Does anyone have any other ideas? Some have said it is a temp sensor issue. How is this corrected?  Could it be an ink cartridge related issue with non-Canon or refilled cartridges?  Is there a way to "reset" or override the error so at least the scanner can be used?  This should be a simple software/firmware update to allow bypassing the print error and still use the copy/scanner functions.

FYI- if cleaning does not work w/reset I suspect the ribbon cable is fatigued...pain to repair , check or reset. When I have time I will tear into it.. Think this is one of 2 parts under constant stress. Thus it cannot identify the HEAD

...UPDATE > After removing the inks, I cleaned the head thoroughly with 91% ethyl rubbing alcohol($1 Walmart). Then let it dry for 4 days because the rubbing alcohol does have 9% water. Maybe did not need to let sit for that long, BUT.... The printer is now working again. IT'S WORKING , IT'S WORKING.. Has worked daily for the past 4 days. Do not know for how long this will last.