cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon Maxify MB2720 Printer keeps giving an error message B504.

Fawnjcol
Apprentice

Today I received a strange error message on my Canon Maxify MB2720 printer. When I tried to print it error message B504 generated. I just purchased this printer in late September 2021. I unplugged the printer and turned it off, but it still doesn't remove the error message. Can someone please help me?

1 REPLY 1

Hector
Product Expert
Product Expert

Hello Fawnjcol,

That error will point to a hardware issue or a problem with one of the tanks in the printer. You can open the front to where the ink loads and you can inspect the tanks to make sure they are all seated properly. If any are sticking out, you can push the tank in so it is properly seated. If that does not work, you can try unplugging the printer from the power and then pressing the power button 10 times while the printer is unplugged. After that, you can plug the printer into a different power source and you can try turning it on.

If you are using third party ink tanks they could also be the cause of the issue. Some third party tanks do not work like our factory tanks and can cause issues with the ink system. We have a service notice about the tanks and you can view it using the link HERE.

In that situation, you can check with the company that made the tank to check what options they have to manually remove the tank from the printer.

Avatar
click here to view the gallery
Announcements