Showing results for 
Show  only  | Search instead for 
Did you mean: 

Canon D420 - Not printing or copying (It just turns ON)


My Canon D420 was just fine few days ago. Yesterday it just turned on and no function is working i tried printing and copying. Can’t figure out what the problem could be. 

Any help would be greatly appreciated. Thanks 



Hi Rg74 


The unit may just need to be reset in order to resolve this issue.  Please unplug the power to the unit for a few minutes then plug it back in and power back on the machine.  Additionally, try plugging the unit directly into the wall outlet as opposed to a surge protector or power strip.


If you continue to have difficulties, please contact our support group using the following link:


Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

Thanks James_C for quick reply. I did as you directed but still not able to print or copy. I was able to scan this time. Not sure where the problem is. I have connected it directly to the power outlet but can't print or copy. 

I hear the printer setting up as I switch it On but after that my print commands just come into queue and dissapear. The printer status says Idle. I would appreciate if you can help me on this one. 




Hi, spoke to the support but not able to solve it yet. As scanning is working they think could be roller or feeder. Will need to take it to service center which I think is not worth it. 


If anyone has any other solution let me know, I did clean the roller too. 


click here to view the gallery