Showing results for 
Show  only  | Search instead for 
Did you mean: 

Another MFToolbox not working on Win7(x64) after months of being successful.




I bought a MF229dw about 10 months ago.  All aspects of the printer/scanner/fax have been working fine until last week.  No changes were made to the laptop except the normal windows update.  Last week, I could no longer remote scan.  I can't initiate a scan from the printer to the laptop and I can't initiate the scan from the MFToolbox, but I can from Presto PageManager.  I am accessing the printer through a wireless network.  I had originally suspected the printer was using an older authentication method that has been disabled by Windows update, but it dawned on me, I don't authenticate between the printer and the laptop.  The printer sees the laptop on the network automatically and I don't have to set any authentication methods and if that was the issue, Presto PageManager wouldn't work.

If I hook up a USB cable, the laptop installs a second 229dw and I can use scanning that way IF I do it from Presto PageManager, but not from the MFToolbox.  I get the standard errors that everyone with this issue seems to get.  "cannot communicate with scanner." "Error code 155,0,0", "MFToolbox that is supported by this scanner you are using may not be installed on your computer.", etc.


I've going back and forth with canon via email for three days and they were no help.  In fact, they did zero troubleshooting and were basically just emailing different things to change without asking hardly any questions.  They even went so far as to send me a patch for Win10, knowing I have Win7x64 and saying "sometimes it works on Win7."  It did not work, in fact, it caused the printer to quit functioning completely and I had to totally uninstall the print drivers and toolbox in safemode, reboot, uninstall everything again, reboot and then reinstall to get it start working again.


I am on Win7x64, running MFToolbox 4.9.  Presto PageManager 9.39.  Things I've tried to date from searching forums is 1.  check the twain_32 folder for the Canon folder and found that I have two folders for the printer.  One that says MF220 and one that says MF220_serial number.  When I uninstall the Toolbox and the scanner, both folders disappear, when I reinstall, both folders reappear.  I've added that path as a system variable.  I've moved one of the folders out of that folder, so that only one Canon folder is there and added the correct path to system variable, which didn't work, so I swapped them and removed the existing one and added the other one back and updated the path in the Path system variables, but no change.  I've left both folders in there and changed the system variable path from one to the other, but no change.


I checked the properties of the WIA service, making sure start up was Automatic and changed the Log on to be Local System Account and checked Allow service to interact with desktop.  I also made sure upon first failure, it was set to restart the service.  I've unistalled the drivers, rebooted, uninstalled the Toolbox, rebooted, reinstalled drivers, rebooted, reinstalled the Toolbox, rebooted more times than I can count and I've done both in Safe Mode and regular mode (You can't install the drivers in safe mode because it can't complete the port configuration).


I also changed the properties of the Toolbox so that it is ran as Admin automatically.  I've been going back and forth on this for several days, so I'm probably skipping some of the stuff I've done, but it's all starting to blur together.


One thing that struck me is canon email support asked me to go into scan properties, from the right-click menu on the printer, under Devices and Printers.  I don't have a scan properties option when I right click on the printer.  I noticed that when I hook up a USB, the second printer that windows installs (to be used with the USB connection) does have the scan properties option.  To my knowledge, there has never been a scan properties option on the right-click menu for the network installed 229dw.  If there was a Scan Properties on the network installed printer, this would be an easy fix, because I could use it to tell the printer to use Presto PageManager.  I do not know of another way to switch my default scanning program for the networked printer.  It's not a complete solution because Presto PageManager is extremely slow in sending the data from the printer to my laptop compared to when the MFToolbox worked, but at least it's a work around that functions.


One thing to note, due to the way the laptop & printer act when initiating scans through various means, it appears the issue lies with the printer sending the information across the network back to the laptop.  When I try to initiate a scan directly from the printer, it says scanning, nothing moves, almost instantaniously a message pops up on my laptop giving the "MFToolbox that is supported is not installed" message and eventually the printer says an error occurred, but if I initiate the scan from the toolbox on my laptop, the scanner starts scanning, and after it is finished and the scanner has returned to it's normal position, I get the error messages on both my PC and the printer, so they are communicating with each other, but MFToolbox doesn't appear to be able to obtain the scanned image. 


Canon sent me an email this morning saying I need to contact them for "rapid" support, and then gave me the normal Canon number.  Of course, there's nothing rapid about the number they gave me and they are closed on the weekends.  I also dread them trying to go through everything we've already done again.  I have rebooted my laptop no less than 20 times over the course of their troubleshooting the last few days.


Does anyone have any other work arounds, or does anyone know how I can change the default program that the printer uses for scanning without going through the non-existent Scan Properties option on the device under Devices & Printers?  Thank you in advance for any and all help.