Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎06-20-2019

Re: Autofocus not working. (18-55mm lens)

Hi all,

 

I have a problem with the 18-55 kit lens which came with my 1100D. It only works whey the camera is fully zoomed out and sometimes will work well for about 10 photos but it will go back to having the issue.

 

When trying to shoot at anything other than 18mm the camera wont make any sound or clicks, it will simply refuse to focus. I've already cleansed the contacts and switched the AF/MF switch a few dozen times.

 

Any solution to this peculiar problem? 

Honored Contributor
Posts: 5,653
Registered: ‎11-13-2012

Re: Autofocus not working. (18-55mm lens)

Sounds like it might be a problem with the ribbon cable. Repair not worth it. 

 

https://photography-on-the.net/forum/showthread.php?t=1414118

 

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Highlighted
VIP
Posts: 10,996
Registered: ‎12-07-2012

Re: Autofocus not working. (18-55mm lens)

" I've already cleansed the contacts and switched the AF/MF switch a few dozen times."

 

Neither of these will help or work.  When did you drop it? Or, when did it get wet?  Or, did you try to focus it manually when it was trying to AF ?

EOS 1DX and 1D Mk IV, even less and less other stuff.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement