Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 5
Registered: ‎04-03-2019

Lens autofocus work using liveview / not viewfinder. Tried two different cameras (EFS 18-55mm Lens)

I have an issue with Auto Focusing on my EFS 18-55mm Lens.  It will autofocus using the LCD liveView screen but not the optical viewfinder.  I'll try not to blab so...

 

  • Mechanically works perfectly (No odd noises, broken gears, etc)
  • Tried two different camera bodies - Same result
  • Reset all settings in cameras
  • Updated firmware
  • Cleaned lense, mirror, electrical contacts, etc.
  • Image looks crystal clear using manual focus
  • Again, autofocus works using view finder
  • Other lenses work as expected on both camera bodies
  • Image stabilizer on / off has no effect
  • Cussing, crying, and other forms of a bad attitude have no effect either.

Any suggestions, ideas, fixes would be most appreciated!!!

Esteemed Contributor
Posts: 3,308
Registered: ‎02-17-2016

Re: Lens autofocus work using liveview / not viewfinder. Tried two different cameras (EFS 18-55mm Le

The only thing you did not try is another lens on that body. 

 

There appears to be a problem with the feedback during normal autofocus. I think the only thing you can do is send it to Canon.

Occasional Contributor
Posts: 5
Registered: ‎04-03-2019

Re: Lens autofocus work using liveview / not viewfinder. Tried two different cameras (EFS 18-55mm Le

Thanks for the feedback.

I guess I left a couple things out. I put multiple lenses on the same body. Basically I played musical chairs with the lenses and bodies. Other lenses work on thar body and the other but the problem lens does not work on either.

Also I did not mention that it mechanically tries to focus. Going through the entire range of motion but it blows by the focused image.

Also if I use manual focus, the focus indicator lights in the view finder give no feedback. No flashing red lights or beeping.

Has any one ever disassembled one of these leses? Could a ribbon cable popped loose?
Esteemed Contributor
Posts: 4,952
Registered: ‎06-25-2014

Re: Lens autofocus work using liveview / not viewfinder. Tried two different cameras (EFS 18-55mm Le


@ingallspw wrote:
Thanks for the feedback.

I guess I left a couple things out. I put multiple lenses on the same body. Basically I played musical chairs with the lenses and bodies. Other lenses work on thar body and the other but the problem lens does not work on either.

Also I did not mention that it mechanically tries to focus. Going through the entire range of motion but it blows by the focused image.

Also if I use manual focus, the focus indicator lights in the view finder give no feedback. No flashing red lights or beeping.

Has any one ever disassembled one of these leses? Could a ribbon cable popped loose?

Or worn out, yes. But if this is to be your first attempt to repair a lens, you should start by assuming that you'll do more harm than good and write the lens off. That's not to say you shouldn't do it, especially if the lens isn't worth the cost of professional repair. It's just that you have to be realistic about your chances of success.

 

Also, could this be one of those cases where someone tried to manually focus a lens when it was in autofocus mode? With some of the cheaper lenses, that can jam the autofocus motor. Sometimes manually forcing the lens can unjam it. Canon has been known to post instructions for trying that.

Bob
Philadelphia, Pennsylvania USA
VIP
Posts: 11,097
Registered: ‎12-07-2012

Re: Lens autofocus work using liveview / not viewfinder. Tried two different cameras (EFS 18-55mm Le

"Could a ribbon cable popped loose?"

 

The camera uses two different focusing schemes to AF in VF vs LV.  The lens does not. It has one way. If the lens does AF using one or the other it suggests the lens is OK. However, it looks like you have eliminated the camera so this seems to be the perfect time to upgrade to a nicer lens.

I would.  Smiley Wink

EOS 1DX and 1D Mk IV, even less and less other stuff.
Moderator
Posts: 1,368
Registered: ‎10-25-2012

Re: Lens autofocus work using liveview / not viewfinder. Tried two different cameras (EFS 18-55mm Le

Hello!

 

Try the troubleshooting on THIS page, just to see if it's a misaligned gear in your lens. This little trick works quite often on the non-STM version of the kit lens.  

 

I hope this helps! 

Occasional Contributor
Posts: 5
Registered: ‎04-03-2019

Re: Lens autofocus work using liveview / not viewfinder. Tried two different cameras (EFS 18-55mm Le

Thank you all for your feed back!


Last night I was out taking photos with my son with the lens on manual focus.  It started making a motor noise seemingly for no reason. Then I took a photo and the camera said, "Lens communication Error". Rebooted. Seemed to work but then after a few photos I heard the motor noise again. Then a communication error. Then I noticed I could hear a rattle if you slightly shook the lens. So, now I know the lens is defiantly physically damaged but it I still wondered… why the communication error?


So going against all advice I took the lens apart. (I love to work on my own things.)


Inside all the gears looked great. as I was rotating the lens I was watching the rotating slide contacts in the lens. That is when I noticed a small piece of flat plastic. It was covering the rotating slide contact. Yep… that explains the communication error. So, I carefully grabbed it. The object is kind of shaped like a warped tear drop. On the flat sides, it has little extrusions, one on each side.

 

That’s when I noticed another identical part inside the view of the lens.


Ahhh… The aperture!

 

Booo!!! Smiley Mad


Is that the sound of Taps playing?

Highlighted
Occasional Contributor
Posts: 5
Registered: ‎04-03-2019

Re: Lens autofocus work using liveview / not viewfinder. Tried two different cameras (EFS 18-55mm Le


@ebiggs1 wrote:

"...this seems to be the perfect time to upgrade to a nicer lens."

 


Any suggestions on a lense that won't break the bank and is compatible with a Rebel T6?

Esteemed Contributor
Posts: 4,952
Registered: ‎06-25-2014

Re: Lens autofocus work using liveview / not viewfinder. Tried two different cameras (EFS 18-55mm Le


@ingallspw wrote:

@ebiggs1 wrote:

"...this seems to be the perfect time to upgrade to a nicer lens."

 


Any suggestions on a lense that won't break the bank and is compatible with a Rebel T6?


That depends on how profitable "the banik" is, but the correct lens for your purpose is the EF-S 17-55mm f/2.8 USM.

 

Unless, of course, you're planning an upgrade to a full-frame camera. In that case, the correct choice is the EF 24-105mm f/4L USM (I or II).

Bob
Philadelphia, Pennsylvania USA
VIP
Posts: 8,041
Registered: ‎08-13-2015

Re: Lens autofocus work using liveview / not viewfinder. Tried two different cameras (EFS 18-55mm Le


@ingallspw wrote:

@ebiggs1 wrote:

"...this seems to be the perfect time to upgrade to a nicer lens."

 


Any suggestions on a lense that won't break the bank and is compatible with a Rebel T6?


If you have a small bank, then you might want to explore a used lens of the same type.  Visit KEH camera.  Use the selection filters to narrow the list of lens choices to Canon lenses, and EF-S Lens Mount.

Look for the “CANON 18-55MM F/3.5-5.6 IS STM BLACK EF-S MOUNT LENS FOR APS-C SENSOR DSLRS”.  This is the upgraded equivalent to the lens that you seem to have received in the camera kit with your camera.  Only buy an 18-55mm lens that has “STM” in the model number.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement