Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎12-16-2012

Focus problem with the 16-35 II on a 5D3

So I bought a Canon EF 16-35mm f/2.8 L USM II on ebay and used it for the first time yesterday.

Using live view to preview my shots, I got very strange, blurry previews which do not occur on my other lenses.

When I was at 16mm it was fine. At 24mm it was still pretty sharp. But when I zoomed almost to 35mm, the live view preview is super blurry. I'm not out of focus; in fact taking the photo and then examining it reveals that the captured image is sharp. But the live view preview is useless and shows the image as totally blurry.

Interestingly, this only affects live view in photo mode. When I switch from photo to video mode, the preview instantly sharpens up to represent what the camera is actually recording. That's what happens in this video, which I shot with my phone. The blurry preview is DEFINITELY IN FOCUS on photo mode. You hear the click of me switching to video mode and the live view preview instantly corrects. Despite no change in settings. 
Do you reckon you can figure out what the heck is going on?

I'd love to know if it's a lens problem or just a simple setting I need to alter somewhere.

Frequent Contributor
Posts: 78
Registered: ‎11-11-2012

Re: Focus problem with the 16-35 II on a 5D3

Does your pictures show that blur area on final image when at tele side of zoom?

 

Do you have a filter on lens? If so remove it and try again.

 

Is there any finger print or dirt mark on front element of your lens?

Check and post more if none applies.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement