Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎03-10-2018

EOS T5 - none of the lenses focus

I have the standard T5 kit from Amazon. It worked well for a couple of years, but today I took it out and none of the lenses would focus on anything - near, far, close. Grrrrr. I tried different settings, both on the camera and on the lenses, and nothing works! Can this camera be saved? Is it the lenses or the camera?

Posts: 13,979
Registered: ‎12-07-2012

Re: EOS T5 - none of the lenses focus

First off don't panic.  In the menus under the Tools tab do a Clear all settings.  Fully charge a battery.  New SD card.  A good one not a cheapo.  Go out side on a nice day with the T7 on green square or P mode.  Lens switch to AF.  Try it.


One word of advice never, never again never buy a camera package from Amazon.  With some of the accessory 'lenes' they supply it is possible to damage your Canon lenses beyond repair.

EOS 1DX and 1D Mk IV and several lenses!
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement