Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎11-02-2015

Canon 50mm f 1.4 lens autofocus quit working

I thought that I would post this for the benefit of others. The autofocus on the above lens just quit working. One day it worked and the next it did not. I Googled the problem and came to this forum where someone had the same problem with their 18-55 lens. I followed the suggestion of "Julius" by manually turining the focus ring all the way in two directions. It worked! There was no audible noise made by the mechanism in either direction as there had been on the 18-55 but it worked. At least for now. thanx

Posts: 13,857
Registered: ‎12-07-2012

Re: Canon 50mm f 1.4 lens autofocus quit working

I had not heard of that with the 50mm f1.4.

EOS 1DX and 1D Mk IV and several lenses!
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement