Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 4
Registered: ‎10-17-2020

Canon 100-400 mm mk1 AF Doesn't Work (Help Diagnoses)

[ Edited ]

 

 

Hi everyone, opening this topic asking for Help, for my 100-400mm canon mk1 diagnoses the AF Problem.

 

I give some time for a dissembly the lens, and i confirm, there is not any residual rusty in the PCB connectors our some flat cables damage.

 

 

Like is says, the AF mode dont turn on and i notice those things:

 

the IS Works on camera

The botton AF/MF dont siwtch on camera (ony MF)

When i use the manual focus and do Half focus Botton, i have the confirmation focus Point, but no Auto focus

 

Waht to you think? 

 

IT is a USM MOTOR our Pcb bionet problem?

 

1.JPG

our usm motor 

2.JPG

[Links removed per forum guidelines.  Images from linked pages added to facilitate discussion.]

 

thanks guys

Highlighted
Esteemed Contributor
Posts: 2,566
Registered: ‎11-19-2017

Re: Canon 100-400 mm mk1 AF Doesn't Work (Help Diagnoses)

Greetings,

I have no idea what your background is or if this version is still under support?  Did you try to call Canon and inquire about service or repair?  Might be worth it.  If this is a 1998 lens, ok, but the 2014 model might still be under support.

 

I'm not sure.  I know others here who own this lens, maybe not the mk1, but they might have more to add.  I hope you'll figure it out.  

~Rick
Bay Area - CA
~6D2 ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~Pixma Pro-100
Highlighted
New Contributor
Posts: 4
Registered: ‎10-17-2020

Re: Canon 100-400 mm mk1 AF Doesn't Work (Help Diagnoses)

Thanks for the reply

im searching for a diy repair at home, but just a repair part confirmation.

 

Highlighted
Respected Contributor
Posts: 1,181
Registered: ‎01-25-2018

Re: Canon 100-400 mm mk1 AF Doesn't Work (Help Diagnoses)

Without at least a schematic, you really can't perform any sort of practical tests at home to determine which section is at fault.  The AF/MF switch is about the only thing you may actually be able to test to ensure that the contacts are actually working on it, use a DMM or even an analog meter.

 

Otherwise, you could either flip a coin as to which module to order first but I would start with which one is cheaper and try it first. Or order them both and try to re-sell the one you don't use on an auction site.  Most places that sell these sorts of parts won't accept returns because of customers either damaging parts or trying to return their own defective part.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video
Highlighted
New Contributor
Posts: 4
Registered: ‎10-17-2020

Re: Canon 100-400 mm mk1 AF Doesn't Work (Help Diagnoses)

[ Edited ]

Thanks wq9nsc

 

The AF/MF switch is about the only thing you may actually be able to test to ensure that the contacts are actually working on it, use a DMM or even an analog meter.

 

I can try take some picures to illustrate the inside connector.

On the first view, the AF/MF switch connector botton, look like new and the flat cables too, no damage signals.

 

Otherwise, you could either flip a coin as to which module to order first but I would start with which one is cheaper and try it first. Or order them both and try to re-sell the one you don't use on an auction site.  Most places that sell these sorts of parts won't accept returns because of customers either damaging parts or trying to return their own defective part.

 

I understand. 

Probably the damage are in the USM motor. but like you said, its a 'flip a coin' situation.

 

can you tell me if the first image 1.JPG replacement part circula PCB part, is related by the Aperture function our is just the electronic information connector from the lens to camera?

 

 

best regards 

Highlighted
VIP
Posts: 13,287
Registered: ‎12-07-2012

Re: Canon 100-400 mm mk1 AF Doesn't Work (Help Diagnoses)

"IT is a USM MOTOR our Pcb bionet problem?"

 

No, it is a Canon service problem.  If you have to ask, you don't have the knowledge to repair it or how to realign it after repair. Call a Canon service center.

EB
EOS 1DX and 1D Mk IV and several lenses!
Highlighted
New Contributor
Posts: 4
Registered: ‎10-17-2020

Re: Canon 100-400 mm mk1 AF Doesn't Work (Help Diagnoses)

thanks for the post,
but does not help in any things
Highlighted
VIP
Posts: 10,710
Registered: ‎08-13-2015

Re: Canon 100-400 mm mk1 AF Doesn't Work (Help Diagnoses)


@NirvanNa wrote:
thanks for the post,
but does not help in any things

As advised, you need to let someone qualified spend some hands on time with it.  That is how electronic repairs work.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement