Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎02-25-2020

Re: Autofocus not working. (18-55mm lens)

Thank you. When I twisted the focus ring I heard a snap. Lens was frozen in position and autofocus could not move it. Works great now.
New Contributor
Posts: 1
Registered: ‎07-15-2020

Re: MANUAL FOCUS NOT WORKING

[ Edited ]
 
VIP
Posts: 11,987
Registered: ‎08-13-2015

Re: Autofocus not working. (18-55mm lens)


@P3rs6 wrote:

MANUAL FOCUS IS NOT WORKING ON MY EOS R WITH RF 70-200MM LENS . PROBLEM WHEN I SHIFT THE SWITCH TO MF ON THE LENS THE CAMREA TAKES THE IMAGE WITH AUTOFOCUS


You renamed the thread, and typed a rant in all caps.  That is really bad internet etiquette.  

 

I suggest that you contact Canon Support directly with your issue.  Your issue is not related to the original issue on the page one.  This is only a user forum.  It is not Canon Support for those who need gear checked, inspected or repaired.  Good Luck!

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Forum Elite
Posts: 14,424
Registered: ‎12-07-2012

Re: Autofocus not working. (18-55mm lens)

Second that post. Smiley Frustrated

 

BTW, Canon's number is 1 (800) 652-2666

EB
EOS 1DX and 1D Mk IV and several lenses!
New Contributor
Posts: 1
Registered: ‎05-17-2021

Re: Autofocus not working. (18-55mm lens)

Julius, you are a genius. I was so downcast that my lens was not working and then I tried your technique and it worked! 

 

New Contributor
Posts: 2
Registered: ‎09-14-2021

Re: Autofocus not working. (18-55mm lens)

I have and I don't have a solution Smiley Sad did you find any advise or solution to this?
Esteemed Contributor
Posts: 4,986
Registered: ‎02-17-2016

Re: Autofocus not working. (18-55mm lens)

Did you try the chiropractic solution listed very early in the thread?

New Contributor
Posts: 2
Registered: ‎09-14-2021

Re: Autofocus not working. (18-55mm lens)

[ Edited ]

@Martmcin wrote:

Hi,

 

Has anyone experienced this issue but only focussing one way? My lens will focus on a subject further away but refuses to focus back to nearer subjects. Its such a pain having to set to manual in order to reset the focus to near everytime!



I have experience the same, it only focus in one direction and I don't have a solution Smiley Sad
 did you find any advise or solution to this issue?
Highlighted
Forum Elite
Posts: 14,424
Registered: ‎12-07-2012

Re: Autofocus not working. (18-55mm lens)

Try this carefully........

  1. Take the lens off of your camera.
  2. Put the lens in MF mode.
  3. Twist the FOCUS ring (the tip of the lens) all the way to one side (extend it). You may hear a click noise or two, this is good, but don't FORCE the lens.
  4. Twist the FOCUS ring all the way to the opposite side (retract it). Again, you may hear a couple of clicking noises. What we hope is happening is the focusing motor being put back into its proper place.
  5. Put the lens back on the camera.
  6. Put the lens in AF mode.
  7. Turn the camera on.
  8. Put the camera in AUTO or P mode.
  9. Take a test photo.
EB
EOS 1DX and 1D Mk IV and several lenses!
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement