Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 5
Registered: ‎04-17-2018

Re: 70-200 f2.8 AF problem

I have almost the identical issue as mish757...a 70-200 2.8 non-IS with a 7D MKii that doesn't focus at all. 4 of my other Canon lenses work perfectly fine. I took the lens to the Canon Service Center and they tried it on a 7D and it worked, so you're right about it not being the lens. Are you aware of any common issues the 7D's have with this particular lens? I even updated the firmware to the latest version. 

VIP
Posts: 12,081
Registered: ‎12-07-2012

Re: 70-200 f2.8 AF problem

"I even updated the firmware to the latest version."

 

Whatever this problem is it isn't the FW.  If the lens worked on another camera, hopefully another 7D, the lens is OK.  If other lenses work on your 7D pretty much confirms the camera is OK.

You need to take both 7D and lens to the service center.  Show them what is going on with your specific gear.

EOS 1DX and 1D Mk IV and several lenses!
Occasional Contributor
Posts: 5
Registered: ‎04-17-2018

Re: 70-200 f2.8 AF problem

[ Edited ]

Thank you for your response! The Canon service techs used a 7D to replicate, then suggested I bring both cam & lens. I read another thread in this forum where someone suggested restoring the camera's default settings...I did and so far, that seems to have done the trick. So far. =)

New Contributor
Posts: 2
Registered: ‎01-21-2020

Re: 70-200 f2.8 AF problem

Did you end up sending in your 70 to 200 to Canon? Why I’m asking is my AF doesn’t seem to be working either. Wondering how long it takes to get it back to you? Did it have to be fixed? Thinking about sending mine in but was wondering how much they charged you? Did they clean it too?
Thank You
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement