Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎06-17-2020

“CaptureOnTouch Lite Launcher” needs to be updated.

[ Edited ]

I have a Canon scanner I purchased last year: Canon ImageFORMULA P-208II. It's been working great, except I just discovered that there is no compatible software for Catalina! Really need to scan some documents. Is there some generic scanning software that will control this scanner? 

 

The pop up message I am getting when I launch the scanner is:

 

“CaptureOnTouch Lite Launcher” needs to be updated.

The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information.

 

Any advice that doesn't involve buying a new scanner or reverting to the previous OS is appreciated.

 

Thanks.

Highlighted
Esteemed Contributor
Posts: 3,201
Registered: ‎11-19-2017

Re: “CaptureOnTouch Lite Launcher” needs to be updated.

[ Edited ]

Greetings,

What version of the Canon Formula software are you running?

 

v1.7.19.1206 is certified for Catalina OS.

 

https://www.usa.canon.com/internet/portal/us/home/support/details/scanners/document-scanner/imagefor...

 

 

~Rick
Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~Pixma Pro-100 ~ImageClass MF644Cdw ~LBP622dw
New Contributor
Posts: 1
Registered: ‎11-18-2020

Re: “CaptureOnTouch Lite Launcher” needs to be updated.

Did you solve this or just get another scanner???

New Contributor
Posts: 1
Registered: ‎03-27-2021

Re: “CaptureOnTouch Lite Launcher” needs to be updated.

This is the second scanner I have had this problem with. Great scanners but I will not be buying another Canon scanner. I feel as though I am wasting my money.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement