Showing results for 
Show  only  | Search instead for 
Did you mean: 

My rebel t1i isn't letting light in

My canon Rebel t1i is not letting light in in manual mode no matter how I change the settings. It looks like there's a grey haize over my lense. I tried using the flash to see if an extreme light would make any difference and the flash won't fire in manual. All the other modes seem to work just fine. Any suggestions?


Are you sure you're not under-exposing?  I can't think of anything that would cause a "gray haze" other than being underexposed.


Try taking a shot on an auto mode (make sure it's bright enough to not warrant using the flash), look at the settings the camera chose, and then take the exact shot in manual mode with those settings.  Is there still a difference in exposure?

I charged my battery, started snapping in different modes and started noticing an underexposed or gray haize in more than one setting so I kept snapping. After messing with it for several minutes and I finally got a shot in auto to go by I tried it and it worked.... but the haize I was noticing lifted before getting that auto shot. .. idk exactly what I did to fix it but it seems to be working now

I figured out the problem! The aperture setting for my lense wasn't holding I started having the issue again and happened to look at the end of my lense to see a tiny little aperture when I had it set pretty high. What's more interesting is that when I click a picture sometimes the apeturw changes going more open with each shot then more closed woth every shot after that. I don't know yet if this can be fixed, if its the lense having an issue or if it is the camera not telling the lense what to do.

The aperture will physically get smaller when you use a higher f-stop value. That's normal.

The f-stop (focal ratio) numer is the number of times the diameter of clear aperture can be divided into the focal length. Hence smaller numbers = larger opening and higher number = smaller opening.

The aperture remains wide open until you take the shot -- then the diaghram blades temporarily slide in to the needed opening size, the camera takes the picture, and they retract again.

But there is "depth of field preview" button which, on your camera (I used to have a T1i) I seem to recall is a small black button just below the button you use to unlock/release the lens (e.g. to swap lenses). That will cause the aperture blades to stop down to the size the camera will use for the shot.
Tim Campbell
5D III, 5D IV, 60Da

Thanks for the input! I actually had just gone through something online that was talking about that button and from doing this multiple times I have indeed found that the blades are stuck lol they do not move when you push the preview button but you can hear them trying to snap.

I also should have been more clear that when the aperture blades were changing openness when I was messing with it earlier they were consistently changing a stop per take and I was not adjusting the aperture at all