cancel
Showing results for 
Search instead for 
Did you mean: 

ImageFORMULA P-215 Scan-tini Software Issues with Windows 8.1 32-Bit Laptop

fhchin
Apprentice

Hi,,

 

I have a ImageFORMULA P-215 Scan-tini scanner which worked without any problems with my Lenovo X230 laptop running Windows 7 64-bit.  However, I have been unable to get the CaptureOn Touch software to work on my Asus Transformer TA100T notebook running Windows 8.1 32-bit. The software and driver installation completed without any errors (without the scanner connected). But when I connect the scanner into the USB port and run the Capture On Touch software, it always comes up with a Microsoft Visual C++ runtime library error - Program C:\Program Files\Canon Electronics\P215\TouchDR.exe abnormal program termination.

 

I tried every possible troubleshooting approaches I could Google online including (1) doing running sfc /scannow (which found no integrity or corruption issues with my Win 8.1 system, (2) did a clean reboot disabling everything except the CaptureOn Touch software and it still comes up with the same error, (3) installing Visual C++ runtime library distributables for 2005, 2008, 2010, 2012, 2013 but still the error pops up. So basically, now I can't use this great little portable scanner with my great little transformer tablet/notebook. 

 

I am wondering whether anyone else have come across a similar problem of getting this scanner to work on a 32-bit Win 8.1 system? Would greatly appreciate any advise.

39 REPLIES 39

olee22
Contributor
I don't know what redistributable break it. I just know how I managed to avoid it.
1. Clean install of Windows (no extra drivers or anything)
2. Create system restore points
3. Install Canon driver
4. Create a restore point before installing anY new software, so I can restore if needed.

My guess is that the Canon driver needs an exact version of the software redistributable. If a newer or older is installed, it breaks the compatibility. So downloading the latest from the MS website actually doesn't help, or at least it didn't help when it was already broken, and I didn't try afterwards. Maybe I will, if I have energy.

thx,so we know that some windows or redist update breaks touchdr.exe, doing a clean install however is not an option for me, it takes days to configure all the other software, so why not fix the issue with touchdr.exe?
I might seem annoyed, but I have several canon scanners that has become unusable due to this issue, and I believe it is time for canon to provide a workable solution?
best regards Thue.

Well, I bought an extra new SSD, to try if a clean install works, and identify the issue.

I also kept the old SSD with the otherwise working setup.

I still did not finish completely migrating the old system to the new SSD.

This whole thing sucks, I would not buy a Canon scanner ever again, for sure.

Hi everybody,

 

during the past weeks, I was in close touch to Canon Switzerland. They did a very nice job and looked seriously to find the error.

The last step would have been, reproducing the failure while a log-software is running. However, to reset all log files in my ->Temp-Folder I decided to delete ALL my temporary data on my Computer. I used the Windows10 settings app for that (System->Storage->TemporaryFiles). All of a sudden, the scanner worked afterwards nicely with the CaputureOneTouch. It still doesn't work with the Windows10 scanner app, but that doesn't bother me.

 

Please try that out and provide feedback, we came among several other issues, which could have an impact as well.

I cleaned the Temp files as you described (Windows 10, latest download of CaptureOneTouch).

Unfortunately, with the Canon DR-C225W, the same errors appear for using CaptureOneTouch.

Smiley Sad

CaptureOnTouch V4 Problem:

 

TouchDR.exe runtime error - visual c ++

 

ok, the solution in my case was:

 

reset the language settings in Windows. Set all options Language&Region to the same e.g. English/United States:

 

- Windows display

- Apps & websites

- Regional format

- Keyboard

- Speech

 

In my case I had setup Windows to have Engish/United states as display language and as Regional format, while the Country or region was set to Germany.

 

CaptureOnTouch stopped working after an Windows update or whatever.

 

My assumption:

The TouchDR.exe is picking up the wrong language/locale setting once the driver of the scanner is activated and exits with the runtime error message.

You can verify the timing by leaving the scanner disconnected until CaptureOnTouch V4 is running. Once you plug in the scanner, the app will crash. However, it is NOT a driver error. The scanner is working well all the time with other Twain-compatible apps. It is still the TouchDR.exe, which is causing the problems.

 

Thank you for sharing your experience. This is actually an interesting assumption because I had an untypical language setting on my laptop as well, probably the same as you. 

Thanks!

 

I had the same problem. I changed all settings to German, now it works.

(Win 10, CaptureOn version: CaptureOnTouchPro_V.4.5.1620.1118)

CanonMarcel
Apprentice

I've ran into this issue multiple times now. It works when starting with a clean installation of windows but you must not forget to install the scanner drivers and software at first because there seems to be an order issue? It is really annoying if you forget to install and test the scanner is working and find out after a week the same issue is back and you can start all over again because it seems unfixable. Also tried other scansoftware (Vuescan), which does work, but I personally find the captureontouch better/easier.

For now I have found a workarround by using vmware player. I've created a clean Windows installation on which I only installed the drivers and the software and everything is working now. I also disabled the networkcard to prevent any windows update from spoiling it. Just to be sure Smiley Wink So if i want to scan I just power on the image and when done, hibernate it so it ready to go when needed. The scanned files i then can move to my own windows.

 

It is not ideal, but easier then re-instalation my entire computer. I'm really happy that it is "working" now but still sad that there is no real solution to this...

bennycode
Apprentice

I am also running into this "abnormal program termination" error on Windows 10 Pro 21H1 with my Canon imageFORMULA P-208 scanner. The CaptureOnTouch Lite software, that is integrated on the scanner, shows me just a start screen but nothing else. That's why I installed the additional ISIS- and TWAIN device drivers and switched the "Auto Start" button on my scanner to "OFF". With the devicer drivers comes a Canon imageFORMULA Utility which lists my scanner (CANON P-208 USB) and shows me that I scanned 467 pages. I thought that this is a good sign and installed Capture OnTouch v2.1 for Windows. When my "Auto Start" button is set to "ON" then this program shows me that I need to connect the USB cable. When "Auto Start" button is set to "OFF" then the program crashes with a "Microsoft Visual C++ Runtime Library" error stating that TouchDR.exe crashed during runtime. As suggested by @JayC1 I exected the "Registry Repair" tool which showed me that it fixed 6 entries but still my scanner cannot be used. Is there any more help available?

Announcements
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
03/22/2022: New firmware version 1.2.0 is available for PowerShot PICK
03/16/2022: New firmware version 1.5.2 is available for EOS-R5
03/16/2022: New firmware version 1.5.2 is available for EOS-R6
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.1.1 is available for EOS-R3
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500
12/2/2021: New firmware version 1.1.0 is available for RF 70-200 F4 L IS USM