cancel
Showing results for 
Search instead for 
Did you mean: 

Canon P-215 II scanner issue on Windows 10

ahr_helpdesk
Apprentice

Hi There,

 

We have a user who uses a P-215 II scanner. He uses with auto mode off, so that he could install and use the desktop application for the respective scanner. 

 

However, all of a sudden the scanner stopped working an throws up an error saying no scanner found. Upon removing the scanner cable and reconnecting it with auto mode on works perfectly. So, I figured this could be due to the drivers and it was indeed showing up that the dirvers aren't taken even though it is already installed and has been working.

 

So I did a complete windows update, ininstalled the software, drivers... etc and reinstalled it again with no success. Device manager still shows that it's not picked up the drivers. I have tried both the USB ports with no luck. So I tried it on a different PC and it was all working fine.

 

Now the question is how can completely delete the drivers and reinstall it, and make it work?

16 REPLIES 16

Danny
Moderator
Moderator

Hi, ahr_helpdesk!

So that the Community can help you better, we need to know exactly which operating system is running on your computer (i.e. Windows or Mac OS, and which version thereof). That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, search our knowledge base or contact our US-based technical support team at http://canon.us/SupportCF

Thanks and have a great day!

Hello, 

 

I am having the exact same problem with these Cannon scanners P215ii I am using windows 10 64bit and using the most current driver that you have showing on the website (215II_DRIT_V10SP4) 

we have several users that use the same computer with different login profiles and for some reason the scanner will work for 1 person but if that person logs off and i have another employee log in witht their own profile the scanner is not recognized. 

the orginal person logged in comes back logs in with her profile and everythig is fine. 

The error message the other users get is "Can't locate device; check cable and power (-4536)

So i know scanner works fine. it is set to OFF  but if i set to ON it works fine for everyone. hope i can get some help on this matter thanks 

I am having a similar problem. We have numerous P-215 scanners. We have recently upgraded several laptops from WIndows 7 to Windows 10. One every one of them, the scanner driver randomly "disappears" and the scanner will not connect. The only solution is to constantly reinstall the driver, after which it will work for a few days before it disappears again. I have contacted Canon about the issue, and their response is " We don't  know anything about it".  On several of the laptops, we have replaced the Canon with a ScanSnap scanner and they work fine, so the problem is with Canon, not Windows 10. 

I get this same error using the wireless connection on the DR-C225 WII. "Can't locate device; check cable and power (-4536)"

BjornNyblad
Apprentice
Me Too, similar problem on Win 10, worked on Win 7.

Was there ever a resolution to this problem? I am still not able to use the P215ii scanner with my windows 10 computer.

Hi bklein.

 

So that we can best assist you, what is the exact error that you receive when scanning from the P-215 II?

 

I look forward to your reply. If you need immediate assistance, please call us at 1-800-OK-CANON (652-2666), Monday - Friday 10:00 a.m. to 6:30 p.m. ET (excluding holidays).

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

I get the "scanner cannot be found", Check power and cables error. I am not able to get it to scan.

Patrice and Danny,

 

In reviewing the thread, we all have the same issue on Windows 10. From my history in working in PC tech support, simply the TWAIN driver is not reaching the apps on Windows 10 64bit.  in my instance, it worked once on a new PC, I uplugged it and plugged it back in the next day and the WIndows 10 64 bit system applications would not see it again, but instead sees it as a a FAT drive.

 

I could post you the error message from the applications I am using but they are not going to be useful because they are non-Canon and application specific.  For example, what is a GIMP dialog going to tell you except when you use the GIMP dialog to pick a TWAIN source, it finds none.

 

To reiterate, the scanner is detected by the system as Storage Disk, not a Scanner. Applications on my Windows 10 64bit  PC will not see the scanner. Yes I (re)installed a new drivers that I downloaded from your site yesterday.

 

Please advise

Announcements

07/28/2022: New firmware version 1.2.1 is available for EOS-R3
07/21/2022: New firmware version 1.6.0 is available for EOS-R5
07/21/2022: New firmware version 1.6.0 is available for EOS-R6
07/21/2022: New firmware version 1.1.0 is available for EOS-R7
07/21/2022: New firmware version 1.1.0 is available for EOS-R10
07/14/2022: New firmware version 1.0.1 is available for CR-X300
07/01/2022: New firmware version 1.3.0 is available for PowerShot PICK
06/30/2022: Service Notice: EOS 70D: Error 70 or Error 80
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
06/07/2022: New firmware version 1.0.3 is available for EOS M50 Mark II
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version 1.0.5.1 is available for EOS-C500 Mark II
05/26/2022: New firmware version 1.0.3.1 is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version 1.0.1.1 is available for EOS R5 C
03/23/2022: New firmware version 1.0.3.1 is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/19/2022: READY FOR ANYTHING EOS-R5 C
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.
01/05/2022: Welcome to CES 2022!
12/7/2021: New firmware version 1.3.0 is available for Mount Adapter EF-EOS R 0.71x
12/7/2021: New firmware version 1.1.1 is available for CR-N 300
12/7/2021: New firmware version 1.1.1 is available for CR-N 500