Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎02-03-2018

lens mount problem

so whenever i wiggle my lens, the camera turns off...its fine if i dont touch the lens but its very hard to use now. does anyone know how to replace the lens mount?

Highlighted
Reputable Contributor
Posts: 861
Registered: ‎01-25-2018

Re: lens mount problem

Does the same thing happen with all of your lenses?  If so take a close look at the contacts on the camera end using a good magnifier looking for a piece of conductive debris or a bit of the contact that is flaking and allowing a short to occur. If it only occurs with one lens then examine the matching contacts on the lens itself looking for the same issue.

 

Which camera body and glass are you using?

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video
Highlighted
New Contributor
Posts: 3
Registered: ‎02-03-2018

Re: lens mount problem

yes it happens with all my lenses. im using the 80D, but now i think its a different problem. now whenever i put pressure on the back grip, it turns off. like even if i just put my finger on it. i have no idea...

Highlighted
Reputable Contributor
Posts: 861
Registered: ‎01-25-2018

Re: lens mount problem

Hopefully someone who has experience with the 80D will chime in but this is probably something that will require a trip to Canon service.  Take a good look at the battery contacts to make sure it isn't something simple like a dirty contact that is mechanically intermittent that but an intermittent condition like this is often due to a cracked trace in a circuit board or in one of the printed connector cables used to connect boards and components.  When you are applying pressure to the lens or back grip you are transmitting a force through the camera body that is distrubing whatever break is causing the intermittent condition.

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video
Highlighted
VIP
Posts: 12,285
Registered: ‎12-07-2012

Re: lens mount problem

Try this Canon support 1 (800) 652-2666.  

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
VIP
Posts: 12,285
Registered: ‎12-07-2012

Re: lens mount problem

BTW, I assume you are using Canon brand lenses (more than one?).  If you are not don't bother calling Canon they will tell you to use Canon brand lenses.

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
Respected Contributor
Posts: 1,716
Registered: ‎11-19-2017

Re: lens mount problem

Remove the lens, turn the camera on.  Hold the camers in natual "shooting" grip.  If it turns off from putting any pressure on the body, sent it to Canon for estimate and/or repair.  

~Rick
Bay Area - CA
~6D2 ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~Pixma Pro-100
Highlighted
New Contributor
Posts: 3
Registered: ‎02-03-2018

Re: lens mount problem

Yeah it's still turning off even without the lens. It's something with the ad card slot because it says "close sd card slot". So how much do you think it would cost to send it to canon?
Highlighted
Honored Contributor
Posts: 5,313
Registered: ‎06-25-2014

Re: lens mount problem


@Samuelsaum wrote:
Yeah it's still turning off even without the lens. It's something with the ad card slot because it says "close sd card slot". So how much do you think it would cost to send it to canon?

Less, probably, than an 80D is worth. So getting it fixed should likely be the preferred option.

 

However, your original question about replacing the lens mount suggests that the camera may have been dropped. If that's the case, or if the camera got wet (a possibility that's not entirely inconsistent with the symptoms), it could drive the repair cost up. If the camera was dropped into salt water, a substance very hard on electronic components, Canon might even be unwilling to take the repair job on at all.

Bob
Philadelphia, Pennsylvania USA
Highlighted
Super Contributor
Posts: 282
Registered: ‎09-29-2015

Re: lens mount problem


@Samuelsaum wrote:
Yeah it's still turning off even without the lens. It's something with the ad card slot because it says "close sd card slot". So how much do you think it would cost to send it to canon?

When you say "close SD card slot",  I remember there was a previous post regarding the SD card slot door micro switch problem. You may take a look at the discussion.

 

http://community.usa.canon.com/t5/EOS-Rebel/Memory-Card-Door-Micro-Switch-Not-Working-All-The-Time/t...

 

It may or may not be just the micro switch problem. It could be the wiring connection or the electronics that cause the malfunctioning. But a look at the tab(micro switch) and a slight press with a toothpick won't do much harm. (especially if you you sending it for repair anyway)

 

Since 80D is still a pretty new camera and I assume that it is still under warranty, I suggest you contact Canon and send it in for inspection and repair if the above small trick can't solve the problem.

 

Good luck.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement