Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎01-02-2013

battery cannot communicate Canon 7D

I have a 7D about 3 years old now. One battery is original , the other is 6 or 7 months old.

I upgraded to the latest firmware version 2.0 shortly there after (Don't know if there is a relationship?) one battery could not communicate, the other worked fine. I recharged it and it worked one time more then errors after that. the second battery worked for about 3 more days then it failed to communicate as well.

 

Questions

1. Batteries ?

2. Charger issue causing chip in battery to go bad?

3. Camera battery sensor chip gone bad ?

 

Any suggestions?

 

Thank you

Jimbo

New Contributor
Posts: 4
Registered: ‎11-14-2012

Re: battery cannot communicate Canon 7D

Try cleaning the contacts on the batteries and in the camera with an eraser.

 

Hope this helps.

 

Pat

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement