Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎06-16-2019
Accepted Solution

With soeedlflash ON (90EX or 320EX) the LCD doesn’t work

I have a 5D4, and strangely I’ve noticed that LCD is not working (neither I can access the Menu on LCD) when EX speedline is TURNED ON (I tried with both 90EX and 320EX).
The only mode I can turn the LCD on is in “automatic” mode, any other mode (AV, P, B, TV, M, C) are not responding and if I try to switch from “automatic” with LCD on to another mode the flash is immediately flashing and then camera turns the LCD off.
I tried: resetting the camera, reset all the setting, update the firmware (now 1.1.2). None of these helped.
I tried using the speedlite on another camera (D100) and I can see the menu in LCD or shooting in live view in any modalities not only automatic.
It’s really strange.
Any help?
Thank you!
Product Expert
Posts: 74
Registered: ‎05-22-2018

Re: With soeedlflash ON (90EX or 320EX) the LCD doesn’t work

Hello Moonman,

 

Welcome to the Canon Forums and thanks for your post!

 

This is definitely an unusual situation. The Speedlite 90EX and Speedlite 320EX can definitely be used on the EOS 5D Mark IV without this kind of behavior occurring. When testing this equipment in-house they worked as expected. One thing I recommend trying is to use a clean, dry, soft cloth to wipe out the hotshoe of the camera and the contacts on the feet of the flashes.

 

If you are still unable to bring up the 5D4 menu on the LCD with either of those flashes attached to the hotshoe, and powered on, please CLICK HERE to reach our friendly Technical Support Team by phone or email.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement