Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎05-25-2018
Accepted Solution

URGENT!! Purple dot on display/video! Should I return my camera?

[ Edited ]

Hello! I have a problem with my brand new Canon EOS 6D. 

Purple dot appears on video (shot under low light) and it's also visible on display (live view mode). 

I'm not certain if this is a pixel because if I zoom in the video on my computer, the purple dot seems to occupy more than just one pixel. Here are the images: 

Video zoomed in: 
https://ibb.co/cJfQ5o

https://ibb.co/mM9Gd8

Video normal size: 
https://ibb.co/exUMBT

Should I return the camera? I'm not an experienced user, so before checking out the tutorials on how to fix this, I'd like to know if this is a serious problem or not. 

Esteemed Contributor
Posts: 3,611
Registered: ‎06-11-2013

Re: URGENT!! Purple dot on display/video! Should I return my camera?

It’s not a stuck pixel ... something is causing a subtle amount of light.  

 

Loads of things can cause this... reflections, ghosting (especially if using a filter on the lens), lens flare, etc.

 

Stuck pixels would be limited to just individual pixels.  

 

Tim Campbell
5D III, 5D IV, 60Da
New Contributor
Posts: 3
Registered: ‎05-25-2018

Re: URGENT!! Purple dot on display/video! Should I return my camera?

Thanks for your answer, Tim. 

I just activated manual sensor cleaning and the dot is now gone. Does this mean it was a hot pixel? 

Highlighted
Esteemed Contributor
Posts: 3,611
Registered: ‎06-11-2013

Re: URGENT!! Purple dot on display/video! Should I return my camera?

No, “sensor cleaning” doesn’t actually clean the sensor.  In front of the actual sensor are a couple of filters.  These handle things like UV/IR blocking and there’s also a low-pass filter (handles anti-aliasing to reduce moire in digital images).

 

Any dust that would accumulate will accumulate on the front-most filter.  The camera uses a piezoelectric effect to vibrate the filter and shake the dust free.  The idea is that you’d point the camera at the floor (with lens removed) and manually invoke a sensor cleaning cycle to (hopefully) shake loose whatever dust is sticking to the filter.  They refer to this as “sensor” cleaning but it’s really “filter” cleaning.

 

Dust is easily spotted in images when you shoot at very high f-stops (e.g. f/16) although it can show up at lower f-stops but it will be harder to notice.  If you ever suspect dust, just shoot a photo at a very high f-stop of something with no contrast such as a plain blue sky or a plain white wall or ceiling (no need to focus).

 

Stuck pixels or hot pixels would be on the sensor itself.  This can also easily be confused for “noise” (and I suppose it is a kind of noise).  Loads of things contribute to noise... heat, quantum effects, etc.  but the biggest contributor is usually something called “read noise”.  It’s usually random but there is pattern noise as well.  Noise is inherent in every digital sensor.   At the camera’s base ISO, noise typically isn’t noticeable.  It’s when you have to apply “gain” (amplify the values read off the sensor) that you start to notice it. 

 

Basically, noise is a result of inadequate exposure... with “exposure” being controlled via shutter speed and aperture but NOT by ISO (ISO is not technically part of “exposure” despite the huge numbers of articles that make claims to the contrary.   An easy way to recognize this is that when you boost ISO, the ISO gain isn’t actually applied until AFTER the shutter closes and the image is captured.). But at that point, you’ve also already captured whatever noise you’re going to get as well.  So when you apply ISO gain, you boost both the signal you want and the noise you don’t want.   If you shot at base ISO and capture a good exposure, you already have all the signal you want and there’s no need to amplify anything... so you don’t boost the noise.  

 

If you shoot in low-light and compensate by using high ISO, you’re going to notice more “noise” in the image ... this is normal.

 

 

 

Tim Campbell
5D III, 5D IV, 60Da
New Contributor
Posts: 3
Registered: ‎05-25-2018

Re: URGENT!! Purple dot on display/video! Should I return my camera?

Whew! Thanks a lot for your in-depth explanation, Tim! Being new to all this, that was very helpful and informative. I really appreciate it! Thanks!! Man Happy  

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement