Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎11-27-2013
Accepted Solution

Playback issue on Canon 5D Mark III:

Used an 8  GB Compact Flash card. JPEG image quality capacity 622.  Shot about 500 pics at a polo match.  Downloaded into Picasa on my computer and Picasa would load only about 337 pics.  Tried to view the remaining pictures on the image screen on the back of the camera, and the screen showed only a thumbnail of the pic and said, "Cannot playback image."  Any ideas why this is happening? 

Highlighted
VIP
Posts: 12,280
Registered: ‎12-07-2012

Re: Playback issue on Canon 5D Mark III:

What brand CF card?

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
New Contributor
Posts: 3
Registered: ‎11-27-2013

Re: Playback issue on Canon 5D Mark III:

Promaster.

Highlighted
VIP
Posts: 12,280
Registered: ‎12-07-2012

Re: Playback issue on Canon 5D Mark III:

Hmmm, I am not familiar with that brand of card but I suspect it is bad or at least going bad. I would not trust it any more.

You can try one of the recovery software's out there to see if the other pictures are retrievable.

I recommend, and only use, SanDisk or Lexar.  (RescuePro comes with or at least used to come with SanDisk cards.)

 

Promaster may be an OK brand and yours just went south on you.

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
New Contributor
Posts: 3
Registered: ‎11-27-2013

Re: Playback issue on Canon 5D Mark III:

Thank you!  I appreciate your prompt response.

Highlighted
New Contributor
Posts: 1
Registered: ‎08-05-2016

Re: Playback issue on Canon 5D Mark III:

Hi there, did you resolve your problem cause it seems i have the same problem. ??? thanks 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement