Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎07-30-2020

New M50 keeps freezing/dying. Support says it's humidity?

Hi,

 

I bought a new EOS M50 at the beginning of June 2020. For a few weeks, it was working well but suddenly it seemed

develop a problem. After shooting some pictures (usually about 40-50), it suddenly becomes completely unresponsible. At times, the image freezes on the touchscreen and even powering off the camera doesn't work. I have to remove the battery. When I reinsert the battery, the camera won't power on. I have a spare battery and sometimes putting it in brings the camera back to life but most of the time, the camera is unresponsive for several hours until I bring it home and charge the battery then reinsert it.

 

It's never been a case of the battery being run down as I've only taken 40-50 pictures before the camera freezes. There are never any error messages, codes, etc.; the camera simply freezes then stops working as described above. This has always happened with the 15-45 kit lens installed. I've tried removing the battery for a couple of days and then resetting the camera to defaults.

 

After this happened several times during vacation trips when I really wanted to take nice pics and ended up having to use my phone camera, I called Canon Canada support. The lady I spoke with immediately told me it's most probably due to high humidity and recommended removing the battery for 48 hours then resetting the camera. She seemed surprised that I saw no error messages and then said if her suggestion didn't work I could send it for service. I tried her suggestion and the camera seemed fine for about 70 pictures but then it again stopped working with the same behavior: picture freezing onscreen, unable to power off until I remove the battery, no response with battery reinsertion or another battery. Four hours later upon returning home, inserting battery brings the camera back to life.

 

As you can imagine this is very frustrating, especially since these are often vacation pictures taken during short trips to scenic areas. I've been searching the internet for similar stories but no one seems to have the same issue. The camera i still under warranty so I can pack it up and send it to Canon but due to the pandemic and their service being closed from March to July, they have a backlog of repairs so it will likely be awhile before I get it back. So I thought I'd join the forum here and see if anyone else had the same problem and found a solution. 

Highlighted
Product Expert
Posts: 175
Registered: ‎07-03-2019

Re: New M50 keeps freezing/dying. Support says it's humidity?

Hi there,

 

It sounds like the best option would be to send the camera for service with a copy of your proof of purchase for warranty consideration. If they find an issue they will be able to take care of it for you and if they don't then that may mean that humidity was indeed the cause. Better to have it checked out soon than to keep missing opportunities to use your new camera.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement