Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎02-05-2020
Accepted Solution

M6 Mark II not recognizing non-electronic lens

I just got a M6 Mark II and a mount adapter for the EF-EFS lens so that I can use my current lenses from my T2i. I am having problems with my Rokinon 14mm wide angle since it doesn't have electronics, fully manual. When I press the shutter release to take a picture, nothing happens. I have the camera set to manual focus and I have Manual mode selected, but is there another setting that I need to check?

 

My other Canon and Tamron lenses that have electronics work fine.

Reputable Contributor
Posts: 786
Registered: ‎01-25-2018

Re: M6 Mark II not recognizing non-electronic lens

With that lens, you may need to go into your custom function section of the menu where there is a setting to release the shutter without lens because it may not recognize that lens as being present.

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video
New Contributor
Posts: 2
Registered: ‎02-05-2020

Re: M6 Mark II not recognizing non-electronic lens

Rodger,

 

Thank you, that was the magic piece of information that I needed. The len works great now.

 

William

Reputable Contributor
Posts: 786
Registered: ‎01-25-2018

Re: M6 Mark II not recognizing non-electronic lens

William,

 

Glad it worked, have fun making some great images!

 

Rodger

EOS 1DX M3, 1DX M2, 1DX, 5DS R, 1D M2, EOS 650 (film), many lenses, XF400 video
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement