Canon Community Canon Community
 


Reply
New Contributor
Posts: 4
Registered: ‎05-25-2021

Lens/camera Focusing Issue

5d Miii camera and kit 24-105L lens. 

I just started using this camera and lens setup at my job so I'm not familiar with its history. I am noticing though that I can switch the auto/manual focus switch on the lens and it won't change in camera. The camera can be on M Focus and yet the lens is switched to Auto. The opposite happens as well. Regardless of where the switch is on the lens, whatever is showing on the screen of the body is how the body and lens with function. Auto focusing while the switch is on Manual. 

Is there a focus override in camera or on the body that I am unfamiliar with? The body is currently setup for half-press on the shutter button for focus, if that matters to know.

 

Thanks!

Frequent Contributor
Posts: 40
Registered: ‎04-01-2019

Re: Lens/camera Focusing Issue

[ Edited ]

I am not sure exactly what you are describing, but Manual on the camera is for manual exposure, not manual focus. If you want manual focus, you must set the Af/Mf switch on the lens to Mf.

 

New Contributor
Posts: 4
Registered: ‎05-25-2021

Re: Lens/camera Focusing Issue

I'm talking about the text on the top LCD screen. It switch from "One Shot" to "M Focus" when switching from Auto to manual focus on the lens, TYPICALLY. But in this case the body isn't matching what the lens is switched to. It's sporadic and there is no pattern. Regardless of what the lens is switch to, the camera and lens respond correctly to what is in the LCD. I just have no consistent way to actually select Manual or Auto focus and get stuck in one or the other often.

Frequent Contributor
Posts: 40
Registered: ‎04-01-2019

Re: Lens/camera Focusing Issue

Did you try to gently clean the lens contacts and remount the lens on the camera? Maybe an intermittent connection with the lens to body contacts. Do you have another lens to try on the body? That is all I can think of that might be the problem.

VIP
Posts: 11,698
Registered: ‎08-13-2015

Re: Lens/camera Focusing Issue

The top of the Quick Menu screen shows the shooting mode.  The AF mode is further down the screen.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
VIP
Posts: 11,698
Registered: ‎08-13-2015

Re: Lens/camera Focusing Issue

If you have not done so already, I recommend that you download a copy of the full User Guide for the camera from here.

 

https://www.usa.canon.com/internet/portal/us/home/support/details/cameras/eos-dslr-and-mirrorless-ca... 

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
New Contributor
Posts: 4
Registered: ‎05-25-2021

Re: Lens/camera Focusing Issue

Okay, just so we are on the same page. At the top of the camera on the quick screen, this typically changes as you switch the the toggle on the lens itself, from manual to auto, reflecting the mode. However as I toggle the switch on the lens, this isn't consistently changing as it should. The lens can be on manual, yet One Shot displays. The camera will shoot with whatever is showing on the screen and not the switch. My guess is a lens issue and I will trouble shoot when I bring my own lens in to test the lens/body. Just wanted to see if anyone else has experienced anything similar.

 

 

Focus.jpg

New Contributor
Posts: 4
Registered: ‎05-25-2021

Re: Lens/camera Focusing Issue

I did a quick clean, nothing thorough. If my test with a separate lens shows the same, I'll give it a better cleaning and test that out. Thanks!

VIP
Posts: 11,698
Registered: ‎08-13-2015

Re: Lens/camera Focusing Issue


@gaijin_rr wrote:

Okay, just so we are on the same page. At the top of the camera on the quick screen, this typically changes as you switch the the toggle on the lens itself, from manual to auto, reflecting the mode. However as I toggle the switch on the lens, this isn't consistently changing as it should. The lens can be on manual, yet One Shot displays. The camera will shoot with whatever is showing on the screen and not the switch. My guess is a lens issue and I will trouble shoot when I bring my own lens in to test the lens/body. Just wanted to see if anyone else has experienced anything similar.

 

 

Focus.jpg


Ah, okay.  The top LCD.  Does it match the Quick Control Screen?  Have you tried a different lens?

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement