Canon Community Canon Community
 


Reply
Highlighted
Honored Contributor
Posts: 5,310
Registered: ‎06-25-2014

Re: Image screen black during operation on eos7D


@Amadden wrote:

Ebiggs

 

Thanks 4your tip. I removed both batteries for 45 min, re-inserted them, but screen still black. Also tried google/ YouTube tips and one chap was successful with a different canon model by leaving both batteries out overnight.  Tried that last night but didn't work.

Googling, I learned that lack of power to image screen is a common problem with different canon models. Solutions included centering the micro switch sensor in the battery chamber with the tip of a ball point pen or scalpel blade tip., and also keeping the sensor realigned with a very small piece of plastic strip, kept in place with a very small bead of glue gun glue. Two other tips by 2 other parties were to also remove the lens and then re-attach it, but that did not work 4 the 2 who tried it,. Two persons said that there is another microswitch in the memory card chamber, but neither could locate it for certain they said.

 

Any other suggestion? Meanwhile, I'll keep googling to learn as much as I can.


You're out of your depth. Anytime you see "sensor" and "glue gun" in the same sentence, you're reading bad advice. Call Canon.

Bob
Philadelphia, Pennsylvania USA
Highlighted
VIP
Posts: 12,272
Registered: ‎12-07-2012

Re: Image screen black during operation on eos7D

"Anytime you see "sensor" and "glue gun" in the same sentence, you're reading bad advice."

 

Amen!  Smiley Surprised Call Canon at this point as the reset didn't help. 1 (800) 652-2666

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎02-04-2020

Re: Image screen black during operation on eos7D

Waddizzle:

o.k. Will not touch microswitches. Afterward, phoned canon support in Brampton ont, because it posted me right after u did.  however, that office has no actual technician, just liaison. Will now contact canon in USA for actual tech support.

 

Noted this am, upon trying to take photo with the black image screen, and the iso at 400 with Aperature at 5.6 , that the shot took about 1full sec to click. (Much slower than normal).  in addition, I note that I cannot change the iso, tho the Aperature can be changed.  These settings I just referred to are those on the lcd panel on top of the camera.

 

As I mentioned earlier many canons acquire a blackened image screen problem, so it's important to find the solution (s).

 

thanks, Alan

Highlighted
VIP
Posts: 9,237
Registered: ‎08-13-2015

Re: Image screen black during operation on eos7D

Taking 1 second to take a shot at ISO 400 sounds like it could be normal to me, if you are shooting in low light using Av mode. I think your display has probably kicked the bucket.
----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement