Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎11-15-2012

I got 7D camara that I attached the battery grip and It was working fine, but not any more

I got 7D with the battery grip and I love to use in the vertical position and the shooting botton in the grip

now is not working, I got the impression that I move something in the setting of the camara that cause me this

problem, any suggestions Please

jfo
Super Contributor
Posts: 280
Registered: ‎11-12-2012

Re: I got 7D camara that I attached the battery grip and It was working fine, but not any more

Do you have the official Canon BG-E7 battery grip?  What setting did you change that you suspect cause this problem?

New Contributor
Posts: 3
Registered: ‎11-15-2012

Re: I got 7D camara that I attached the battery grip and It was working fine, but not any more

Is there an  On/ Off Switch on the  BG ?

 

Greets

BDeKid

New Contributor
Posts: 3
Registered: ‎11-15-2012

Re: I got 7D camara that I attached the battery grip and It was working fine, but not any more

Yes the BG is the Canon made and thats the one the goes for 7D camara, of course the switch is on....

New Contributor
Posts: 3
Registered: ‎11-15-2012

Re: I got 7D camara that I attached the battery grip and It was working fine, but not any more

Yes of course the switch is on position....

Occasional Contributor
Posts: 18
Registered: ‎11-14-2012

Re: I got 7D camara that I attached the battery grip and It was working fine, but not any more

[ Edited ]

Not much to go wrong in these grips.  That is why asking if the switch on the grip is in the on position was a fair question.

 

If the switch on the grip is turned on then you must have a problem with either the button or the switch on the grip, or possibly the connec tion between the camera and grip. There isn't any camera settings that would cause the button on grip to malfunction.  Try removing and reseating grip.

Occasional Contributor
Posts: 17
Registered: ‎11-14-2012

Re: I got 7D camara that I attached the battery grip and It was working fine, but not any more

i JUST had that problem - its fixed now

 

over time the shutter release on the batt grip just got harder and harder to get to trigger

 

i "thought" it was the dial that screws the grip to the body - that is, i thought the contacts weren't making a good connection and "tightening" the grip to the body would make it better - it "seemed" to work, but now i'm doubtful it ever did

 

but eventually i couldn't use it at all - of course, that had to happen in kona hawaii during the ironman world championship!! :/

 

so, last friday i took it in to the service center - i got it back today (the hurricane back east disrupted the shipment/availability of parts)

 

the repair form indicates they changed two components:  cover ass'y, front and base ass'y, tripod

 

it cost me ~$62 labor ----- doesn't appear as if they charged me for the parts (gold members get 30% off labor ---- approx $90 otherwise)

Occasional Contributor
Posts: 17
Registered: ‎11-14-2012

ps..

ps... it seemed so strange to shoot without the grip! lol

 

i had gotten used to it - the weight, the dimensions, being able to shoot vertical comfortably...

 

without it, the cam body is "small" and light and it feels weird to put my hand "on top" of the camera to shoot - uncomfortable! haha

 

(end commercial for batt grips!)

Smiley Wink

New Contributor
Posts: 4
Registered: ‎11-14-2012

Re: I got 7D camara that I attached the battery grip and It was working fine, but not any more

Do you have batteries in the grip?

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement