Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎12-17-2015

I am running the OS XI El Capitan OS on my Mac and the EOS Utility does not run on this version.

The EOS Utility throws up a message saying It cannot run on this version of the OS on my Mac. Anybody has a workaround for this problem ?

Any idea when Canon is planning an upgade to the EOS Utility to run on the OS XI El Capitan OS ?

Honored Contributor
Posts: 5,599
Registered: ‎11-13-2012

Re: I am running the OS XI El Capitan OS on my Mac and the EOS Utility does not run on this version.

https://www.usa.canon.com/internet/portal/us/home/support/details/cameras/support-dslr/eos-1d-mark-i...

 

Download 2.14.20a. Works fine on my MacBook El Cap.

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
New Contributor
Posts: 2
Registered: ‎12-17-2015

Re: I am running the OS XI El Capitan OS on my Mac and the EOS Utility does not run on this version.

Thank you very much. I am sure that will solve my problem.

Ravi

New Contributor
Posts: 2
Registered: ‎05-22-2017

Re: I am running the OS XI El Capitan OS on my Mac and the EOS Utility does not run on this version.

Hey I am having the same issuse, Did you resolve the problem? I am running El Capitan 10.11 with a 60D and can;t get it working, I get to the stage when I go to open the downloader and nothing opens? 

Honored Contributor
Posts: 5,599
Registered: ‎11-13-2012

Re: I am running the OS XI El Capitan OS on my Mac and the EOS Utility does not run on this version.

Have tried downloading this version?

 

IMG_0570.PNG

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LRCC Classic
Esteemed Contributor
Posts: 3,800
Registered: ‎06-11-2013

Re: I am running the OS XI El Capitan OS on my Mac and the EOS Utility does not run on this version.

I'm currently running macOS Sierra but I've never had a problem with any of the Canon versions ... even when I was running El Capitan.  I do have a 60Da (identical to the 60Da except for the filter) along with a few others.

 

EOS Utility needs to be versions 2.x of the 60D / 60Da... not version 3.x series.

 

I have both 2 and 3 on my Macs.  My 5D IV and 5D III work with EOS Utility 3 but EOS Utility 3 will not recognize my 60Da... EOS Utility 2 _does_ recognize my 60Da.

 

 

Tim Campbell
5D III, 5D IV, 60Da
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement