Canon Community Canon Community
 


Reply
Frequent Contributor
Posts: 47
Registered: ‎12-25-2013

Help my 70D on the fritz!!!!

Two days ago my 70D stopped recordning images on normal mode where I snap the pic looking through the viewfinder.  The image is left black but the numbering and ISO setting show in the corners.  However, it works fine live mode.  I switched out SD cards and it still did it.  I can't find anything on the WEB regarding this problem.    I am suspecting one of the contacts in the camera that transfer images to the SD card in normal mode may be dirty or damaged.  The camera is less than a year old and I probably have anywhere from 10.000 to 15,000 pictures taken with it.   I will take it to our local canon outlet tomorrow unless I can figure out a remedy by then.

Respected Contributor
Posts: 1,005
Registered: ‎10-23-2012

Re: Help my 70D on the fritz!!!!

Hi Yorptunes!

 

Thanks for posting.

 

Try restoring the camera to the default settings by doing the following:

 

 1. Press the <MENU> button.

 2. Select the [Tools #4] tab.

 3. Select [Clear All Camera Settings].

 4. Select [OK].

 

Now, set the MODE DIAL to AUTO and take a picture using the viewfinder.  Is the image still completely black when it is recorded?

 

 

If this is a time sensitive-matter, additional support options are available at Contact Us.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Frequent Contributor
Posts: 47
Registered: ‎12-25-2013

Re: Help my 70D on the fritz!!!!

Mike:  Thank you for your response.  I took the camera to the local canon service center,  They said there is something wrong with it electronically and will fix it under warranty.  Very nice people, great service, no hassle with warranty.  I can only say buy Canon!!!

 

John

Highlighted
Frequent Contributor
Posts: 47
Registered: ‎12-25-2013

Re: Help my 70D on the fritz!!!!

Ok got my 70D back today and it is working fine, covered by the Canon Warranty.  Just for curiosity sakes it was the Mirror Box that broke.  They replaced it and good to go.   Thanks for the help, Cheers, John  

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement