Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎04-11-2016

Has any one else had problems with the EOS 7D MKII back focus button?

I upgraded from the 7D to the MKII last year and all went fine until a few weeks ago. Now, when I use back button focus, the focus point jumps to the centre while focusing then back to the point I chose. This doesn't happen if I assign the AE lock button to focusing but I prefer to use both independantly.

 

I'm fairly sure I may have change something in the settings but can't locate it. The other option is a hardwear fault.

 

I'm sure there's a genius out there with an answer.

 

 

VIP
Posts: 13,989
Registered: ‎12-07-2012

Re: Has any one else had problems with the EOS 7D MKII back focus button?

Set it back to factory defaults.  In the menu "Clear all settings".  Then start all over.

EB
EOS 1DX and 1D Mk IV and several lenses!
Honored Contributor
Posts: 5,558
Registered: ‎06-25-2014

Re: Has any one else had problems with the EOS 7D MKII back focus button?


@ebiggs1 wrote:

Set it back to factory defaults.  In the menu "Clear all settings".  Then start all over.


Yeah, you're probably right; it's the expedient action. But I can understand why Hugh was hoping that someone could come up with the exact setting that got munged. Recovering from "Clear all settings" can be a tedious process.

Bob
Philadelphia, Pennsylvania USA
New Contributor
Posts: 2
Registered: ‎04-11-2016

Re: Has any one else had problems with the EOS 7D MKII back focus button?

[ Edited ]

"Set it back to factory defaults.  In the menu "Clear all settings".  Then start all over."

 

That was one of the first things I tried. Unfortunately the MKII backup battery is internal so I'm not able to do a full reboot.

VIP
Posts: 13,989
Registered: ‎12-07-2012

Re: Has any one else had problems with the EOS 7D MKII back focus button?

The internal battery should only keep things like the date and time set, etc.  Clear all settings and perhaps Clear all Personal settings should do it.  I have sold my 7D and I don't have a 7D Mk II so I am unfamiliar with the exact menus.  Somebody else (Bob from Boston) should be able to tell you exactly how.

EB
EOS 1DX and 1D Mk IV and several lenses!
Esteemed Contributor
Posts: 2,387
Registered: ‎11-14-2012

Re: Has any one else had problems with the EOS 7D MKII back focus button?

I'm pretty sure you've set it to do that & can reverse that setting in one of the AF menus. Get your manual out & read up on just what you want it to do & you'll likely find where you went wrong. 

"A skill is developed through constant practice with a passion to improve, not bought."
Esteemed Contributor
Posts: 2,387
Registered: ‎11-14-2012

Re: Has any one else had problems with the EOS 7D MKII back focus button?

One more thought to check. Does it do the same thing in both One Shot & AI Servo? Maybe you switched between them to have it react as it now does.

"A skill is developed through constant practice with a passion to improve, not bought."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement