Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎06-01-2017

Exposure Compensation Control Dial on 5d Markiii fail to work

This is a brand new camera (only had it for a couple of days) and it worked the first couple of times I tried but now it doesn't do anything when I turn the back dial. I tried searching the forum but didn't find my specific issue. I checked the manual and it says the "Lock" must be in off postion which true but still nothing. The only way to get EC to work is by going into the settings under Expo.compAEB shooting MENU. Any tips would be greatly appreciated. Wil

Respected Contributor
Posts: 1,861
Registered: ‎12-02-2012

Re: Exposure Compensation Control Dial on 5d Markiii fail to work

That kind of sounds like what happens if you are in M mode. No exposure compensation there, only bracketing. 

Scott

Canon 5d mk 4, Canon 6D, EF 70-200mm L f/2.8 IS mk2; EF 16-35 f/2.8 L mk. III; Sigma 35mm f/1.4 "Art" EF 100mm f/2.8L Macro; EF 85mm f/1.8; EF 1.4x extender mk. 3; EF 24-105 f/4 L; EF-S 17-55mm f/2.8 IS; 3x Phottix Mitros+ speedlites

Why do so many people say "FER-tographer"? Do they take "fertographs"?
New Contributor
Posts: 2
Registered: ‎06-01-2017

Re: Exposure Compensation Control Dial on 5d Markiii fail to work

Thanks for the reply. I am using AE mode and just now tried TV mode and nothing as well. 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement