Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎05-26-2021

EOS77D won't connect to Canon Connect app


Trying to connect my EOS77D to the Canon Camera Connect app. I go through the procedure on the menu of the camera then on the iOS device select the camera and enter the password.

The iOS device shows it as having connected, but on the 77D's screen it just hangs on "waiting to connect" and never goes any further.

I've tried with both an iPhone and iPad but the same result.

Any tips to help? Thanks

Posts: 11,698
Registered: ‎08-13-2015

Re: EOS77D won't connect to Canon Connect app

Are you using Bluetooth to establish the connection?  Try resetting the camera back to factory defaults.


"Doctor told me to get out and walk, so I bought a Canon."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement