Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎05-21-2016

EOS Utility not working with El Capitan: 5D MKIII

Hello, All.

I have the latest Mac OS - El Capitan and I cannot make the EOS Utility work.

I know there is an update and after downloading, the EOS utility will not recognize my CF card and will not download pictures. Very frustrating. What can I do to make sure it works for sure? Thanks!

Esteemed Contributor
Posts: 3,854
Registered: ‎06-11-2013

Re: EOS Utility not working with El Capitan: 5D MKIII

This sounds like it's possiblly a couple of different issues.

 

I run OS X El Capitan 10.11.5 and can confirm that the EOS Utility does work.

 

However... you do not need to use EOS Utility to get the Mac to recognize the CF card.  If you're inserting your CF card into a reader and it's not being recognized by the Mac then something else is wrong.    

 

I had a CF card reader that worked under Yosemite, but the CF slot stopped reocgnizing my cards (the USB slots still worked) after I upgraded to El Capitan.  The vendor sent a firmware update and now that reader works fine under El Capitan.  So you might have an issue with your reader.  I also have a Lexar brand CF reader and that thing has worked solidly on every OS.

 

As for EOS Utility... make sure you're running the latest version of EOS Utility.  You can get it here:

 

https://www.usa.canon.com/internet/portal/us/home/support/details/cameras/dslr/eos-5d-mark-iii

 

(select the "software" category and make sure it indicates that it is displaying software for OS El Capitan 10.11)

 

EOS Utility can be used to import the images via USB cable from the camera and can be used to control other aspects of the camera (tethered shooting for example) but is not needed to read images from the CF card (assuming you're inserting the card into an attached CF card reader.)

 

There are no software drivers, etc. needed to use the camera with a Mac.

Tim Campbell
5D III, 5D IV, 60Da
New Contributor
Posts: 1
Registered: ‎03-07-2015

Re: EOS Utility not working with El Capitan: 5D MKIII

I had a similar problem with EOS Utility 2.  Downloaded EU 3, and it worked as expected.  

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement