Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎08-07-2014

Re: EOS Remote not detecting WIFI connected 6D

[ Edited ]

The wifi connection is not the problem. The wifi connected just fine. But once it was connected, it wouldn't pair with the camera - in the EOS App, there was nothing listed under "Detected Cameras", even though both phone and camera showed that the wifi connection was fine. See the OP's image above - mine looked just the same, in spite of being connected via wifi.

 

I did eventually find a solution, for anyone who has this problem in the future. I had just upgraded my phone (from iphone 4s to iphone 5s), and had previously connected the camera to my old 4s with no trouble. When I got the new 5s, I initially set up the 5s from my icloud backup of the old 4s. To fix the camera-pairing problem, I had to completely erase my new 5s phone and go back through the phone's set-up process, setting up the 5s as a NEW iphone, instead of selecting "Set up from icloud." Then I cleared the wifi settings from the camera, downloaded the EOS app again, and went back through the camera set-up process. Ta-da, it worked. So I think the camera was trying to pair with the old phone - it didn't realize this was a new device. Kind of a pain that I couldn't automatically get my old phone's settings transported to the new phone just because of this app, but at least I figured it out and it's working now! Thank you everyone.

New Contributor
Posts: 1
Registered: ‎09-24-2015

Re: EOS Remote not detecting WIFI connected 6D

I have this exactly same problem. Wi-Fi connection works, but the mobile software can't detect the camera. And that solution mentioned in the previous message won't work, because i have not changed the phone since I got the 6D and downloaded the mobile software. The problem occurs in both softwares, EOS Remote and Camera Connect. My phone is LG G3.

New Contributor
Posts: 1
Registered: ‎01-12-2017

Re: EOS Remote not detecting WIFI connected 6D

I am having a similar issue to this. I'm trying to connect my HTC One A9 (Android 6.0.1) with my Canon EOS 1300D using Canon Camera Connect app for Android. Initially it worked fine and I was enjoying the ability to remotely shoot photos and download pictures straight on the phone for at least two days. For some reason it stopped working at some point (I noticed this after an Android OS upgrade) and the app just never managed to detect the camera. This is the case whether I use the built-in wifi on the camera or by connecting both devices over my home wifi.

 

The odd thing is that my other Android phone could connect to it without any problem, but I really wanted to get it working on my current phone.

 

After failing to connect on multiple tries, I did a full reset on both devices:

1) Cleared my Canon camera settings

2) Factory reset my Android phone

 

I set up the connections again from scratch, but to my surprise the app still DID NOT manage to detect the camera. I performed factory reset on both devices at least 3 times to make sure, but the phone just wouldn't detect the camera.

 

To investigate a little further, I downloaded the EOS Remote app, and again that also did not detect my camera.

 

This problem really baffles me but I have a feeling that it has something to do with the MAC address of the phone because that is the only thing that remains the same even after completely resetting the phone, and which also explains why other phones had no problem to connect to it as they have a different MAC address. Does Canon EOS cameras store a previously saved MAC address in its internal memory that somehow gets corrupted and would never respond to the phone's request anymore? Is there a way that we can clear off the Canon EOS internal memory? (I figured that clearing Canon settings to factory default does not necessarily clear off its internal memory).

 

The last thing that I can probably try to overcome this is to root my Android phone and change its MAC address, but I'm hoping not to have to come to that!

 

Any help is much appreciated!

VIP
Posts: 8,665
Registered: ‎08-13-2015

Re: EOS Remote not detecting WIFI connected 6D

Your 1300D is a very different wireless device from the EOS 6D.  The 6D offers more capability.

 

If the OS updated, then I would suggest deleting the app from your wireless device and re-installing it.  I am not sure if your 1300D has the smarts to be able to pick and choose connecting to multiple wireless devices.  I don't think so.  I hope I'm wrong.

 

I find the built-in wireless capabilities not very useful for transferring photos.  I shoot RAW files, almost exclusively, and you cannot transfer RAW files using the built-in wireless.

 

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
Highlighted
VIP
Posts: 8,665
Registered: ‎08-13-2015

Re: EOS Remote not detecting WIFI connected 6D

You can always call 1-800-OK-CANON for assistance, too.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement