Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎12-16-2020

EOS RP AF operation Settings is only coming up as 'M' instead of "Servo" or One Shot"

Hi Canon Users

 

im new to Canon Family. i have recently Purchased Refurbished EOS RP camera and trying to configure the settings.

 

1st problem is,  AF operation is Set to 'M' and i cannot see "Servo" or One Shot" options. why is this so?

 

2nd problem is, i cannot take any pictures using my EFS lens with mount adapter. Is this an issue?

 

Appreciate if someone can help me 

 

Jay

VIP
Posts: 11,551
Registered: ‎08-13-2015

Re: EOS RP AF operation Settings is only coming up as 'M' instead of "Servo" or One Shot&q

What lens are you using?  Is it an autofocusing lens made by Canon?

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
New Contributor
Posts: 3
Registered: ‎12-16-2020

Re: EOS RP AF operation Settings is only coming up as 'M' instead of "Servo" or One Shot&a

Hi

 

I have Used Mount Adapter "VILTROX EF-EOS R Auto Focus Lens Mount Adapter Compatible with Canon EF/EF-S Lens to EOS R/R5/R6/RP Camera" and then Lens is Canon Zoom EF-S 18-55 MM 1:3.5-5.6 IS STM

 

i even ordered Canon RF 35mm f/1.8 IS Macro STM Lens and waiting to receive the order

 

Jay

VIP
Posts: 11,551
Registered: ‎08-13-2015

Re: EOS RP AF operation Settings is only coming up as 'M' instead of "Servo" or One Shot&a

Check the position of the AF/M switch on the lens.  It needs to be in the AF position for autofocusing operation.

 

If the autofocus is still unavailable, then you have a problem with the Viltrox mount adapter. 

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
New Contributor
Posts: 3
Registered: ‎12-16-2020

Re: EOS RP AF operation Settings is only coming up as 'M' instead of "Servo" or One Shot&a

Actually i tried to configure evrything agin with Auto focus mode and i can see the AF operatoin now with Servo or One SHot option.

 

Thank you for your Prompt response 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement