Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎12-04-2020

EOS M50 screen not working

My M50 arrived in the mail December 2 and worked great right out of the box. I didn't do much with it besides look around in the settings. When I woke up the next morning, the touchscreen no longer showed anything. All I get is a black screen. I can still view stuff through the viewfinder, but obviously I need the screen to work aswell. I've tried googling and checking Youtube and Reddit for fixes, but nothing has worked. I also emailed Canon but did not get any confirmation emails that my message was received. I have no clue what I should do as this was the first camera I've ever purchased and it randomly broke within 24 hours and less than 15 minutes of use time.

Esteemed Contributor
Posts: 4,685
Registered: ‎02-17-2016

Re: EOS M50 screen not working

If there is an "info" button, try pressing it a couple of times.

Frequent Contributor
Posts: 40
Registered: ‎04-06-2019

Re: EOS M50 screen not working

That model switch automatically display off whenever the sensor beside the viewfinder window detect you placed your eye on it, be sure there is nothing in front of it and check if its surface is clean from fingerprints or other that could trick its working.

New Contributor
Posts: 2
Registered: ‎12-04-2020

Re: EOS M50 screen not working

Yeah, I looked at all that stuff. I ended up taking it to a local camera shop and they weren't able to figure it out either. Came to the conclusion that it was most likely a loose wire so they're shipping it off to Canon for me. Thanks though!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement