Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎07-24-2013

EOS M issues, doesn’t turn on

I have an old EOS M with the 22mm lens. I haven’t used it in a while, and now when I try to turn it on, the power light comes on for a second, and the lens positions itself, and then it is dead. I thought maybe this was a battery issue, but with a new battery I am having the same issue. Anyone have any ideas that may be causing this issue? Thanks!
Highlighted
VIP
Posts: 11,680
Registered: ‎08-13-2015

Re: EOS M issues, doesn’t turn on

It is time to eliminate possibilities.  Let's do some basic troubleshooting.  

 

Remove the memory card and lens.  If it still does not power up without the lens and memory card, then you probably have a camera problem.  I do not know if that model is still serviced by Canon, or not.  If it does power up, go into the menus, and reset the camera back to factory defaults.  Put the Camera in P mode to reset it.

 

If the camera seems to work after removing the lens and memory card, you want to add the memory card and test it again.  

 

If the camera seems to work after installing the memory card, remove it, and then test it again with just the lens installed.

 

If it is still working by this time, let's test it with both the memory card and lens.

 

Good Luck.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement