Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎06-21-2019

EOS 70D - Help! Vertical grey line in every picture

I need some help. My EOS 70D has started to have grey vertical line in every picture.

  • I have done the following:
  • reset all setting
  • updated to the latest firmware
  • tried mutliple lens
  • occurs on every setting
  • Cleaned the sensor
  • blown our the sensor (no hair in there)

Despite all of that, the line shows up when you review the pic on the camera as well as the actual picture when viewed from the card.

 

IMG_1398.JPG

Highlighted
Reputable Contributor
Posts: 580
Registered: ‎01-25-2018

Re: EOS 70D - Help! Vertical grey line in every picture

That is most likely a fault with the image sensor itself or with the electronic interface to it.  You need to contact Canon, hopefully it is still in warranty but otherwise they can help you decide upon a course of repair.

 

When you get such a perfectly straight line, it won't be from external debris but instead is a problem with a component.

 

One column of the sensor isn't being properly scanned so you have null data from that column of sensor cells.

 

Rodger

EOS 1DX M2, 1DX, 1D M2, EOS 650 (film), many lenses, XF400 video
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement