Canon Community Canon Community

Honored Contributor
Posts: 5,087
Registered: ‎06-25-2014

Re: EOS 20D in 2017 help?

@ebiggs1 wrote:

LR3 may not be new enough.  LR4 has some upgrades that 3 doesn't.

I guess I could believe that LR3 might not be new enough to work with some modern operating systems, but I have a hard time believing that it wouldn't support the 20D. According to Wikipedia, the 20D preceded even the first beta release of Lightroom by more than two years (August 2004 vs October 2006).

Philadelphia, Pennsylvania USA
Posts: 11,678
Registered: ‎12-07-2012

Re: EOS 20D in 2017 help?

Bob for Boston, Mass.


"LR3 may not be new enough."


I have no idea because I don't LR3 any longer and I never had a 20D of my own.  But knowing Adobe I would not be surprised they were behind the curve.  If LR3 had it, LR4 got all the camera models LR3 had plus the bug fixes it didn't have.  Give me a break there Robert!

EOS 1DX and 1D Mk IV and several lenses!
Occasional Contributor
Posts: 6
Registered: ‎05-15-2017

Re: EOS 20D in 2017 help?

Lightroom is not the problem here gentlemen ;-) At least I really don't think so.


I say that because I tried to pair 20D with Lightroom 5 and 6 without success. And for some bizarre reason, it only worked with LR3...well, 50% success:


- Lightroom would not recongnize the 20D unless the EOSU was running in the background. Only then it would tether the camera correctly.


-Almost 1 out of 2 shots would not make it through to show up in lightroom. I often had to press the shutter again so that a picture would download correctly in lightroom for review.


Less than ideal!


The shoot is today. I'll have to make it without a review screen. But I still can't put this to bed yet. A simple solution HAS to exist.

Posts: 11,678
Registered: ‎12-07-2012

Re: EOS 20D in 2017 help?

With my experience about using Adobe PS and LR since it was, tells me if 3 worked 4, 5, 6, will also.  Something else is wrong.  I suppose Adobe 'could' remove cameras form LR as they age but no in just the next version.

The conclusion that EOSU needs to be running for LR to work is flawed, I would bet EOSU running in the background is an issue not a help.


Your next best move would be to call Adobe.  However, they may not support LR3 any longer.

EOS 1DX and 1D Mk IV and several lenses!
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement