Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎04-03-2013

Dust or grease found on new 7D sensor, could not remove it.... Is this common ?

I found what looks like dust or grease on my new 7D sensor, I only have about 200 cycles on camera, I
Could not remove with bulb air blower....
Any body else have seen this issue ? This is my second EOS camera, with no issues after 5-years....
I read about all the issues with assembly grease on the sensors of the Nikon D600.
Any info would be great !!!
I have made arrangements for sending 7D in to Canon for warranty.
I'm not a happy camper right now I have only had the camera 5-days..... ):
Good day to all !!!!!
VIP
Posts: 11,475
Registered: ‎12-07-2012

Re: Dust or grease found on new 7D sensor, could not remove it.... Is this common ?

I have a 7D and a friend of mine from NPR has two and none of these 7D's have any issues. So, no, I would say it is not "common". It is a pretty small sample, however. I am sure Canon will make it right.

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
New Contributor
Posts: 2
Registered: ‎04-03-2013

Re: Dust or grease found on new 7D sensor, could not remove it.... Is this common ?

I didn't think so.......
Thanks for the reply, all send it off today. After talking to Canon service, it was nice it wasn't a phone operator in India or somewhere like that.
The Canon warranty tech on the phone hasn't heard of this issue either......
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement