Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎12-17-2013

Canon T2i - Auto focussing is not correct when used with Canon Speedlite 430 EX II

Hi,

 

I am facing this issue continuously with my Canon T2I & Speedlite 430 EX II, when I use this speedlite, I don't get sharper images (most of them are Ok images) but if I remove speedlite and take normal shot with my camera, I get sharper images.

It seems to me, it doesn't focus properly when using with speedlite. I tried every setting and finally I try to take shots without speedlite. Could some please help me to understand the problem?

 

Thank you!

Esteemed Contributor
Posts: 3,809
Registered: ‎06-11-2013

Re: Canon T2i - Auto focussing is not correct when used with Canon Speedlite 430 EX II

When you attach a 430EX II speedlight, there is a red af-assist beam which fires a pattern onto your subject making it possible for the camera to focus in the dark.

 

I'm wondering if the camera is having a problem using this -- it would only be used when the flash is attached.

 

You can test by disabling it.  See page 194 of your T2i manual. 

 

You'll use the menu system to navigate to Custom Function III (C.Fn III) and choice 7 (C.Fn-7) on that page should allow you to control the AF-assist beam setting.  By default it is set to '0' which enables it.  You can change it to '1' to disable it (other choices are '2' to only use AF-assist on an external speedlite and '3' which is to use AF-assist beams only if it's the red IR beam (some flashes fire visible light to focus).  On your 430EX II speedlite, settings 0, 2 or 3 will all cause the AF-assist beam on the flash to be used... only setting '1' will disable it.

 

ALSO note that it's possible to set custom functions on the flash itself (rather than on the camera) and this can be used to disable the AF-assist beam.  

 

It's nice to have a working AF assist beam and I'm not sure what would cause the camera to miss focus only when the flash is used -- it is normally accurate.

 

Tim Campbell
5D III, 5D IV, 60Da
Highlighted
New Contributor
Posts: 2
Registered: ‎12-17-2013

Re: Canon T2i - Auto focussing is not correct when used with Canon Speedlite 430 EX II

Thank you Tim.

 

I'll try with disabled assist beam and share the results.

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement