Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 7
Registered: ‎09-07-2021
Accepted Solution

Canon RP

I'm in the learning mode with the EOS RP I bought.  I'm attempting to use it for astrophotography.  I'm using a Pixel remote timer.  Timer works great when I have a lens attached to the camera.  The issue I'm having is when I connect the camera to a field flattener on my telescope, I can't seem to get the timer and camera to work together.  The timer clicks off the seconds, but the camera does nothing.  I checked the plugs and all, and no problem.  Put a lens on the camera, it works. Take the lens off and ust the t ring connect to put it back inline with the field flattener, and nothing.  What am I missing?  I have a EF control adapter ring on the RP so that I can use my EF lens.  Is there a setting, or what?

Reputable Contributor
Posts: 988
Registered: ‎12-24-2013

Re: Canon RP

You need to go into the Custom Function menu and enable shutter release without lens.

 

6C6571C2-310F-433A-8D99-929D85C6195F.jpeg

 

2A08EA99-BADF-4924-8AEB-071699CE17C6.jpeg

Mike Sowsun
80D, 5D Mk III
Occasional Contributor
Posts: 7
Registered: ‎09-07-2021

Re: Canon RP

Thanks Mike.  The RP has way more versatilitiy and features than any camera that I've ever own. I suspected that it was a setting or something, but I didn't know where to  start looking.  Again, thank you very much.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement